Wrong timezone on my system

Hello Tempesters!
My Tempest woke up after having several weeks winter sleep! Waiting for next sleep…

How can I change the timezone showing on “Tempest station map”? The existing timezone is Europe/Oslo when it should be Europe/Helsinki and there is 1 hr difference.

-Jani

time zone is set by the stations location. There is no separate setting for it. Perhaps try shifting it around to trigger that procedure again. If it fails, contact support.

Continuing the discussion from Wrong timezone on my system:

From the webpage for your station (Tempest where XXXXX is your station id) select Settings > Stations > [Your Station Name] > Location and move your station around on the map to put it in the proper location. This should set the lat/long for your station and then your time zone should be correct.