WeatherFlow PiConsole

Hi @peter ,

Thank you for the explanation! Makes perfect sense. I’ll flash a new card with Buster and go from there.

If anyone has a console that needs to upgrade from Stretch to Buster, here’s a step-by-step guide:

The process didn’t mess up any PiConsole settings. After the upgrade, I updated PiConsole and was back in business. Very easy.

In theory, you should make a backup of your card or start with a fresh card. I threw caution into the wind and updated on my live card (worst-case, I would have to reinstall the PiConsole). Worked great.

2 Likes

Hi @vinceskahan,

Thank you for the reply! Updating the OS was a fairly easy process, so I’m back in business.

@peter

Just doing a required system rebuild on one of my PCs. Installed Windows 10 Pro - from scratch … I put that off as much as possible, as many would appreciate. The problem I ran into is restoring the Miniconda and getting all the other dependencies installed for python & kivy. I couldn’t find a Miniconda 3.7 - All that was obviously available was 3.8. Kept getting a bunch of errors during your walk-thru instructions. Also The “Installing the kivy stable release” - is no longer specified on the page - link that was provided.
I uninstalled the 3.8 - and found an earlier version in my downloads folder - I installed that - things got a bit further. However; as soon as I tried to install kivy - I ran into trouble. I’m wondering if you could take a look - and perhaps update your instructions for the Windows 10 - installation instructions? Perhaps it will still be possible to get wfpiconsole working on Windows 10.

Sure - I’ll take a look at this. It will definitely still be possible, just need to work out the steps!

I have looked into this, and I think the easiest solution for now is to install Kivy into a Conda virtual environment running Python 3.7. At some point I need to update the console to Kivy Version 2 (it is currently running Version 1.11.1), which will make it compatible with Python 3.8. You should be able to follow these instructions to get up and running:

  1. Open Miniconda and create a new virtual environment running Python 3.7:
    conda create -n kivy_venv python=3.7
    (enter y when prompted to continue)

  2. Activate that environment:
    conda activate kivy_venv
    (you will need to do this every time you open Miniconda)

  3. Install the required Python modules:
    python -m pip install autobahn[twisted] pytz pyasn1-modules service_identity geopy ephem Cython numpy packaging distro pyopenssl pillow docutils pygments pypiwin32 kivy.deps.sdl2 kivy.deps.glew --extra-index-url https://kivy.org/downloads/packages/simple/

  4. Install Kivy:
    python -m pip install kivy==1.11.1

  5. Download the PiConsole:

cd && mkdir wfpiconsole && cd wfpiconsole
curl -sL https://api.github.com/repos/peted-davis/WeatherFlow_PiConsole/tarball -o PiConsole.tar.gz
tar -xvf PiConsole.tar.gz --strip 1
del /f PiConsole.tar.gz

Let me know if this gets you up and running again!

@peter

I kinda got it working… until it didn’t. All was going fine till the 5. Download the PiConsole:
got a bunch of syntax type errors. I understood what you were trying to do and broke out the commands
separately, and got it downloaded and extracted. Got past the setup questions for my unit. Then all went fine till it tried to obtain a socket…

(kivy_venv) C:\Users\tomc>cd wfpiconsole

(kivy_venv) C:\Users\tomc\wfpiconsole>python main.py
[INFO ] [Logger ] Record log in C:\Users\tomc.kivy\logs\kivy_21-02-28_6.txt
[INFO ] [deps ] Successfully imported “kivy_deps.glew” 0.3.0
[INFO ] [deps ] Successfully imported “kivy_deps.sdl2” 0.3.1
[INFO ] [Kivy ] v1.11.1
[INFO ] [Kivy ] Installed at “C:\Users\tomc\miniconda3\envs\kivy_venv\lib\site-packages\kivy_init_.py”
[INFO ] [Python ] v3.7.10 (default, Feb 26 2021, 13:06:18) [MSC v.1916 64 bit (AMD64)]
[INFO ] [Python ] Interpreter at “C:\Users\tomc\miniconda3\envs\kivy_venv\python.exe”
[INFO ] [Factory ] 184 symbols loaded
[INFO ] [Image ] Providers: img_tex, img_dds, img_sdl2, img_pil, img_gif (img_ffpyplayer ignored)
[INFO ] [Window ] Provider: sdl2
[INFO ] [GL ] Using the “OpenGL” graphics system
[INFO ] [GL ] GLEW initialization succeeded
[INFO ] [GL ] Backend used
[INFO ] [GL ] OpenGL version <b’4.0.0 - Build 10.18.10.4252’>
[INFO ] [GL ] OpenGL vendor <b’Intel’>
[INFO ] [GL ] OpenGL renderer <b’Intel® HD Graphics 2500’>
[INFO ] [GL ] OpenGL parsed version: 4, 0
[INFO ] [GL ] Shading version <b’4.00 - Build 10.18.10.4252’>
[INFO ] [GL ] Texture max size <16384>
[INFO ] [GL ] Texture max units <16>
[INFO ] [Window ] auto add sdl2 input provider
[INFO ] [Window ] virtual keyboard not allowed, single mode, not docked
[INFO ] [Text ] Provider: sdl2
2021-02-28 13:17:44-0500 [-] Log opened.
2021-02-28 13:17:44-0500 [-] Starting factory <main.WeatherFlowClientFactory object at 0x00000219382C5048>
[INFO ] [Base ] Start application main loop
[INFO ] [Support ] Starting twisted reactor
[INFO ] [GL ] NPOT texture support is available
2021-02-28 13:18:04-0500 [-] dropping connection to peer tcp4:34.202.254.239:443 with abort=True: WebSocket opening handshake timeout (peer did not finish the opening handshake in time)
2021-02-28 13:18:09-0500 [-] Websocket connection closed
2021-02-28 13:18:09-0500 [-] Websocket connection retrying
2021-02-28 13:18:09-0500 [-] <twisted.internet.tcp.Connector instance at 0x219382c5248 disconnected IPv4Address(type=‘TCP’, host=‘ws.weatherflow.com’, port=443)> will retry in 5 seconds
2021-02-28 13:18:09-0500 [-] Stopping factory <main.WeatherFlowClientFactory object at 0x00000219382C5048>
2021-02-28 13:18:17-0500 [-] Starting factory <main.WeatherFlowClientFactory object at 0x00000219382C5048>

EDIT: FYI clock still updates however takes 4-5secs –

Opps - that was a code formatting error. Different lines were running into each other. I have fixed it in the original post.

The socket issue is different though. Is you internet working OK otherwise, as I don’t see the same issue on my Windows 10 machine using the instructions I gave above?

OK. The download went fine, however missing the mkdir wfpiconsole, and cd wfpiconsole -

so once I did that manually -- it worked perfectly...

Yes, internet is fine as the download happened in seconds. I also as a test, turned off my firewall. Still the same issue.

EDIT: also to confirm internet – the forecast comes it fine as well… ?

@peter

I wanted to confirm, so as NOT overlooking something that may be a point of confusion. I Found and installed Miniconda from a download I had found on my PC - Miniconda3-latest-Windows-x86_64. didn’t know what version it was/is so from command line …
image

were all those instructions for version 3.8 ?

EDIT: Nevermind – I went back and uninstalled 3.7 - installed a fresh download of 3.8 – went through the installation again, and it does the same thing.

image

EDIT: not sure if it matters but this is the build info of Windows 10 Pro - is/was suppose to be 20H
image

I really don’t know what is going on here. I wiped miniconda off my machine completely, installed a fresh download of 3.8, went through the installation and everything is working fine. The conda version is 4.9.2 and the Python version is 3.7.10

If you are happy too, can you share the Personal Access Token you are using (or generate a new one that you can then delete). I can test that my end and see if somehow it is station specific

I sent you a message with both of my wfpiconsole.ini files (TXT) extension.

I just installed from scratch - on a different PC. However, it was also just built from a NEW Windows 10 Pro - Creator USB utility.

I’ve got another PC running an older version, however it does take updates… I’ll try installing on that one, to see if it makes a difference.

Peter, thanks for the guide. I gathered the supplies and downloaded PiConsole, set it up and just that easy I have my dedicated display in the family room.

Thanks

1 Like

Peter
I am still having the same issue
Sent you a message with the requested info
Thank you
Keith

1 Like

No, I was running the prior (or maybe the prior prior) version of the OS. Updating fixed the problem (after 12 hours or so, updating the OS is slow).

1 Like

Previously my Tempest was communicating and updating Pi Console data perfectly. Then, I had to replace my Tempest due to failure (Hub not changed). After updating the Pi Console station ID per the new Tempest, and re-booting the Pi Console, I still have no updates received by the console and the Tempest shows as offline??? Note that the tempest data is being updated when viewed on the IOS App and also via WEB access. Any thoughts? Station ID 21593

If you did a Replace Device the Station ID would not have changed. The Device ID would have changed.


Maybe you need to enter the Device ID rather than Station ID?

I used the “Replace” feature of the iOS App when I swapped the Tempest and the weather data is reported correctly both to the iOS APP and via the WEB reporting so I know the HUB is communicating with the Tempest and with the internet.

For the Raspberry Pi Console, I did update the Tempest Device ID via settings to the new “72102” and confirmed that the station ID had not changed.

The Raspberry PI Console is connected to the internet as I do receive forecast updates.

I don’t think I need to do any API or Token updates.

BTW, I did upgrade the WeatherFlow PI console to the latest version 4.0.4 and Re-booted.

Any other ideas?

Thanks,
Doug

Can you first delete the entire wfpiconsole.ini file. Then restart the console with wfpiconsole start and enter the correct station and device id’s. If it doesn’t work, can you share the logs that are printed to the terminal?

Ok, I deleted the wfpiconsole.ini, restarted wfpiconsole, entered the station and device ID’s, and the original API and Token data. Then I printed out the .ini file and verified correct entries.

I rebooted wfpiconsole and still no data reported.

I’m not sure of which error log you are referring. Is it the error log requested under the wfpiconsole directory or requested under the raspberry pi directory?

I’m thinking to start over from scratch with the whole wfpi install.

Doug