WeatherFlow PiConsole

Welcome @greggmarco7,
I moved your question here where some one may help you.
It might pay to read earlier replies to learn what other information you could supply to help people to understand your situation.
Personally I do not have a solution for you sorry.
Good luck cheers Ian :slight_smile:

Sorry you are having issues. Can you open a terminal and run this command

sudo apt update

and let me know what errors you see printed to the screen?

Did you manage to solve this? Someone else face this issue last week - see their post here.

I’ve had a good look into this and I cannot recreate the behaviour you see. Sorry! Everything for me is logging to the bottom of the file as expected. When using the auto start function, all the logging is handled by systemd (I just tell it where to do the logging), so perhaps you have a system setting that has reversed the logging order? Sorry I can’t be of more help!

Thank you so much, that resolved my issue as well. I turned off PiConsole for a couple hours, restarted and everything is working again. Must have been some issue that caused me to disconnect and then timeout, with the failure causing me to get rate limited by the API.

Maybe if the check fails, it should retry at decreasing rates over time. Once every minute for 10 minutes, every 5 minutes for 30 minutes, 30 minutes for 2 hours, etc.

I got this as well “Error: Unable to update local package cache. Please check your internet connection”

I did an apt-get update and got this:
Repository ‘Index of /raspbian buster InRelease’ changed its ‘Suite’ value from ‘stable’ to ‘oldstable’

Researching that lead me to a post saying:
It’s nothing to worry about. The main Raspbian repository tracks the Debian repositories . Debian has just upgraded from Buster to Bullseye.

Which lead me to another post that had this as a solution:
Solution 1. sudo apt-get update --allow-releaseinfo-change

I did this and was able to perform updates as needed

1 Like