WeatherFlow PiConsole

@vinceskahan thanks for the detailed error message, and thanks @alextaylor1 for your patience. I have tried a few clean installs, but am still struggling to get the Console to install on Raspbian Buster. I’ll keep trying and let you know how I get on.

Hi Alex - good news! I’ve tracked down the source of the issues and the console now installs correctly on Rasbian Buster. I’ll push an update tomorrow, and then hopefully you can get up and running.

@alextaylor1 All the changes to the code have been uploaded to the Git repository, so you should be able to go ahead and install the console on a fresh image of Rasbian Buster using the command:

curl -sSL https://peted-davis.github.io/wfpiconsole | bash

Do let me know how you get on. Cheers!

It ‘did’ indeed compile for me on a pi3 - so thanks a bunch !

Now if I only had a official screen to try it on. Buried deep in the thread is there a partslist of what we need to add to a pi to drive this puppy in its native environment ?

Great! Glad it’s working. The only part you need for the full console experience is the official 7 inch touchscreen (and case of your choice)!

Trying to justify the $75-100 for the display and case, but the software certainly works fine on Buster. Thanks a bunch for the updates…

1 Like

Hi, I was successfully able to install wfpiconsole on a rpi running Buster… Didn’t see any errors anywhere along the process… However when I try to run the configuration process, when I get to the Station ID part, I get this:

Please enter your Station ID (required): xxxx
Please enter your outdoor Air module ID (required): xxxxxx
Please enter your outdoor Sky module ID (required): xxxxxxx
Station ID not recognised. Please re-enter your Station ID (required):

I pulled my station ID and module IDs from the Status page, as per the docs, but the script doesn’t seem to like them… I can see my stations with current data on smartweather.weatherflow.com so I don’t think the issue is there… Any thoughts on where to look for problems?

thanks

Can you say what you exactly fed the script as station, air and sky id ??
as you can see from the xx, the length is not the same between station id and device id … (4 versus 6 digits)

Sorry… I’m a little paranoid by default… :slight_smile:
7920 26758 26759

I’m not 100% sure but did you set your station private ??

If so, I think the script can’t get your data (being set private)
Try to toggle off the private setting and see if it works.

Yep. Setting it to public fixes that issue… Thanks.

1 Like

Hi @jtw! Thanks for checking out the console, and I’m glad you have manged to get up and running with @eric 's help (thanks!). Unfortunately WF do not provide a way yet for third party applications to access data from private stations - even if it is the station owner that wants access. As soon as they provide a way, I’ll update the wfpiconsole.

2 Likes

Hi Peter sorry for the delay, finally had a chance today to have another go and the updated version is working perfectly. Thank you so much! Ordered a screen and case, looking forward to having a play :slightly_smiling_face:

Great! Glad to hear it :smiley: . Let me know if you run into any issues.

Hi Peter,

Should the console run a Pi4? The script installed without errors on a fresh copy of Buster. I’m using a monitor (1280x1024). Error below when trying to start.

pi@raspberrypi:~ $ wfpiconsole start
[INFO ] [Logger ] Record log in /home/pi/.kivy/logs/kivy_19-07-13_6.txt
[INFO ] [Kivy ] v1.11.1
[INFO ] [Kivy ] Installed at “/usr/local/lib/python3.7/dist-packages/kivy/init.py”
[INFO ] [Python ] v3.7.3 (default, Apr 3 2019, 05:39:12)
[GCC 8.2.0]
[INFO ] [Python ] Interpreter at “/usr/bin/python3”
[INFO ] [Factory ] 184 symbols loaded
[INFO ] [Image ] Providers: img_tex, img_dds, img_sdl2, img_pil, img_gif (img_ffpyplayer ignored)
[INFO ] [Window ] Provider: egl_rpi

  • failed to add service - already in use?

BTW v2.9 is running fine on my Windows PC.

Thanks, Peter

Hi Peter, there is no reason why it shouldn’t run on the Pi4. The problem though is that due to the increased processing power and RAM on the the Pi4 it comes with a new graphics engine, and this is likely causing the issues that you are seeing. Unfortunately, I don’t have a Pi4 to test the code on.

There are a couple things to try though that will help me with the troubleshooting. Firstly, can you start an instance of Python in a terminal window on the Pi4 by using the command python3. Once python starts, can you copy and paste these commands in order:

import platform
print(platform.system())
print(platform.machine())
print(platform.platform())

The last three commands should print an output to the terminal. Can you let me know what it prints? Once you’ve finished, you can close the python interpreter with the command exit().

Then can you open the file main.py in the wfpiconsole directory and comment out lines 22 and 23 and lines 219 and 220. Lines 22 and 23 should read this:

if platform.system() == 'Linux' and 'arm' in platform.machine():
	os.environ['KIVY_GL_BACKEND'] = 'gl'

and lines 219 and 220 should read this:

if 'arm' not in platform.machine():
	Window.size = (800,480)

Comment them out by putting a # at the start of each line. Save the file and then try and run the console again. Let me know what you see this time.
Cheers!

Hi Peter,

Output from the code:

import platform
print(platform.system())
Linux

print(platform.machine())
armv7l

print(platform.platform())
Linux-4.19.57-v7l±armv7l-with-debian-10.0

I tried commenting out lines 22/23 and 219/220 but still the same error.

I have limited knowledge of Python but fluked it by googling.
if platform.system() == ‘Linux’ and ‘arm’ in platform.machine():
os.environ[‘KIVY_WINDOW’] = ‘sdl2’
and need remove “not” to get window to size correct only my larger monitor.
if ‘arm’ in platform.machine():
Window.size = (800,480)

For me its not necessary to run on a Pi4, its just that I had one so thought I would try.

Thanks, Peter

Thanks for letting me know the output and for info on how you managed to make it work. I’ll try make the logic in the code cleverer so it can tell whether it is running on a Pi4. I may need to come back to you to ask you to try out a couple more things. Cheers!

Finally got everything I needed to build the PiConsole. install when very smooth. Great job on this.

Great! Glad you like it. Let me know if you see any issues.