WeatherFlow PiConsole

I did the console update today and afterwards I get hung up at Websocket: Connection Open and the start never completes. Has anyone else seen this issue after updating to the latest wfpiconsole?

Did you leave an issue on the GitHub page as well? Try deleting your wfpiconsole.ini file and then restart the console. You’ll be prompted to re-enter your station details, and then you should be up and running again

I did not post it there but I will next time. Thank you for the suggestion.

Don’t worry - posting here is completely fine. I just had a very similar question asked on GitHub at the same time and I was wondering if it was a cross posting. Saves me some effort!!

If my suggestion doesn’t work, can you post a screenshot and the contents of the log that is either printed to the terminal or is contained in the wfpiconsole.log file. That’ll hopefully help me understand what is going on.

Hello

I have wfpiconsole running on a rpi 3B+. When i run it, eventually i just get a white blank screen. I have the pi running through HDMI to a 20" (ish) monitor. Also the wfpiconsole log shows a much of “@@@” with a carat before it. this is all running through SSH terminal. the last error i get on the ssh is something about rainfall being none.

thank you for your help

Sorry for the slow response. Can you share the output of wfpiconsole.log, or whatever is being printed to the screen?

I think the issue you may be having is caused by your use of SSH. If you want to connect to a pi remotely to start/stop the console, I highly recommend using VNC. There are instructions on how to get that running here: Raspberry Pi Documentation - Remote Access

It seems I have other issues, right now when i try to start i"m getting a “unable to fetch station metadata”

Please can you share the output of wfpiconsole.log , or whatever is being printed to the screen? A photograph is also fine. It makes providing support a lot easier!

Also make absolutely certain that the value of the Weatherflow key in the .ini file is correct

Keys are good

this is the wfpiconsole.log this is also what is being printed on the screen. I did see some errors in the kivy log as well

[^[[1;32mINFO^[[0m ] [Logger ] Record log in /home/pi/.kivy/logs/kivy_22-06-09_2.txt
[^[[1;32mINFO^[[0m ] [Kivy ] v2.0.0
[^[[1;32mINFO^[[0m ] [Kivy ] Installed at “/home/pi/.local/lib/python3.7/site-packages/kivy/init.py”
[^[[1;32mINFO^[[0m ] [Python ] v3.7.3 (default, Jan 22 2021, 20:04:44)
[GCC 8.3.0]
[^[[1;32mINFO^[[0m ] [Python ] Interpreter at “/usr/bin/python3”
[^[[1;32mINFO^[[0m ] [Config ] Verifying station details
[^[[1;31mERROR^[[0m ] [Config ] Unable to fetch station metadata

Ok, can you share the full contents of your wfpiconsole.ini file with me in a private message? That will help me investigate the issue

Don’t know how to do that sir

If you tap a user’s username it will pop up an option to message that user. Just attach the file to that message.

That doesn’t seem to be an option for me. I only have the 1 post thus far if that is an issue.

I have raised your status and you should now be able to send PM’s. Let me know if it is ok.

Is there a way to have the piconsole software setup for example have my weatherflow data show for like 20 seconds and then go to a live radar page for 20 seconds and then go back to the weatherflow data on the screen if that makes sense. Basically i want it to change from radar to piconsole tempest weatherflow data every 20 seconds. Is this possible? Radar data may could come from NOAA or where ever. Can someone help?

Unfortunately this is currently not possible

Looking for HELP… My Tempest sensor failed. - I worked with support to determine that, and I replaced it. Just received it today…

Went into the Tempest App on my iOS device - deleted my old ST-000072xx under manage devices. Powered up the new Tempest - ’ + added’ new device - it discovered it. - I selected it and it was added.

Checked all the readings… seemed fine from the app. I tried getting wfpiconsole to see it and it doesn’t. What am I doing wrong? – do I have to change anything in the wfpiconsole.ini ??

image

EDIT: I also notice that my old device INFO page is still showing within the App??

Yes, it’s likely that the device ID of the new Tempest is different. You’ll need to change that value in the .ini file

what is that parameter label name is it under?

[Station]
StationID = 41xxx
TempestID = 123443
SkyID =
OutAirID =
InAirID =

NEVERMIND … I found it listed under DEVICE ID within the App.

Thanks!

1 Like