WeatherFlow PiConsole - Archive

Beta fixed my problem of it closing whenever I pressed menu.

Thank you for all your time and effort



The Beta fix worked for me too, Thanks again for you help!


All is working fine. Thank you for your timely fixes.

1 Like

So…. I’m ignorant. I readily admit.
I have wfpiconsole running on an old laptop with Ubuntu.
Whenever I have had an update to to wfpiconsole or to Ubuntu, I have tried to follow the directions to update and everything seemed to be happy.
Recently, this notification show up on my screen in the livingroom. I ran “wfpiconsole update” on the terminal and it when thru gyrations & updated something, but this notification window didn’t go away.
So…. What do I do? What information do you need to tell me what to do? Any assistance will be gratefully appreciated.
I already know I’m ignorant, so save your breath. Thanx …… jt

I am not going to claim to be an expert, but, in my experience, this occurs if something on your system needed to be updated, and it is asking for input to continue with the update (for me, it was usually weewx). I had to do something like a “sudo apt update” followed by a “sudo apt full-upgrade” (responding to any prompts that come up) and then redo the upgrade.

By the way, there is a very good support thread for wfpiconsole at Announcements & Updates. The product author watches that thread and responds pretty quickly … usually solving the problem.

I’ll try your suggestion and then move to tge developer thread. Thank you very much!…. Jt

A whole bunch of stuff happened. You said try upgrade or update again?

So I did that and then ran wfpiconsole start
Again and I still have the window in the original photo.
I did a wfpiconsole update on the terminal and then wipiconsole start.
I still have the image I posted.

As the message on the screen says, run wfpiconsole update.

BTW, you might want to wait a day or two, some bugs were found. Best to check the status in the thread @wx3i09 linked.

Hi there

I have just run the upgrade, but the console is now unable to open and tries to auto start a couple of times unsuccessfully.
The screen changes as it tries to load, but then crashes before anything shows up. I’m using a Pi4 with the latest updates.
I have tried shutting down and disconnecting all power.
Here’s what I get when trying to manually run:

Traceback (most recent call last):
File “”, line 518, in
File “/home/pi/.local/lib/python3.7/site-packages/kivy/”, line 950, in run
File “/home/pi/.local/lib/python3.7/site-packages/kivy/”, line 582, in runTouchApp
File “/home/pi/.local/lib/python3.7/site-packages/kivy/”, line 347, in mainloop
File “/home/pi/.local/lib/python3.7/site-packages/kivy/”, line 387, in idle
File “/home/pi/.local/lib/python3.7/site-packages/kivy/”, line 733, in tick
self.post_idle(ts, self.idle())
File “/home/pi/.local/lib/python3.7/site-packages/kivy/”, line 776, in post_idle
File “kivy/_clock.pyx”, line 616, in kivy._clock.CyClockBase._process_events
File “kivy/_clock.pyx”, line 649, in kivy._clock.CyClockBase._process_events
File “kivy/_clock.pyx”, line 645, in kivy._clock.CyClockBase._process_events
File “kivy/_clock.pyx”, line 218, in kivy._clock.ClockEvent.tick
File “/home/pi/wfpiconsole/lib/”, line 75, in fetch_forecast
threading.Thread(target=self.generate_forecast(), daemon=True).start()
File “/home/pi/wfpiconsole/lib/”, line 255, in generate_forecast[‘Pres6’] = derive.SLP([np.nanmean(Pres6).tolist(), ‘mb’], pres_device,[0]
File “/home/pi/wfpiconsole/lib/”, line 176, in SLP
elevation = float(elevation) + float(height)
ValueError: could not convert string to float:

Sorry you’re having issues. Can you share the contents of your wfpiconsole.ini file with me in a private message? Thanks!

Sorry, how do I send a private message? I can’t find the option.

Just click on/tap his name and select Message.

This is odd. Can you delete/rename your existing wfpiconsole.ini file and then start the console again with wfpiconsole start? You will taken through the steps to generate a new one. Once that has finished, do you still see the same behaviour?

I had the same problem updating. Before reading any forums, I decided to go for a fresh install on my Pi3.
However installing stops at kivy python install. Tried it several times, both with sd card and usb, and left it for hours, but it stops at kivy install.

Welcome to the forums!

Can you let me know which problem you were facing?

Can you copy and paste the error message you see so I can investigate further. Can you also run these two commands and let me know the output:

lsb_release -a
cat /proc/device-tree/model

Hi @Peter,
thanks a lot for the beta :slight_smile:

And yes, already now the shutdown is working properly :+1:


Thanks Peter.

pi@Weatherflow-PiConsole:~ $ cat /proc/device-tree/model
Raspberry Pi 3 Model B Rev 1.2pi@Weatherflow-PiConsole:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 11 (bullseye)
Release: 11
Codename: bullseye
pi@Weatherflow-PiConsole:~ $ cat /proc/device-tree/model
pi@Weatherflow-PiConsole:~ $ curl -sSL | | bash

[✓] Root user check passed
[✓] Hardware check passed (aarch64)
[✓] OS check passed (Debian GNU/Linux 11 (bullseye))

Installing WeatherFlow PiConsole

[✓] Checking for updated packages
[i] No updated packages found

[i] WeatherFlow PiConsole dependency checks…
[✓] Checking for git
[✓] Checking for curl
[✓] Checking for rng-tools
[✓] Checking for build-essential
[✓] Checking for python3-dev
[✓] Checking for python3-pip
[✓] Checking for python3-setuptools
[✓] Checking for libssl-dev
[✓] Checking for libffi-dev
[✓] Checking for libatlas-base-dev
[✓] Checking for jq

[i] Installing WeatherFlow PiConsole Python modules…
[✓] Updating Python package manager
[✓] Installing Python module cython
[✓] Installing Python module websockets
[✓] Installing Python module numpy
[✓] Installing Python module pytz
[✓] Installing Python module ephem
[✓] Installing Python module packaging
[✓] Installing Python module pyOpenSSL

[i] Kivy Python library dependency checks…
[✓] Checking for ffmpeg
[✓] Checking for libsdl2-dev
[✓] Checking for libsdl2-image-dev
[✓] Checking for libsdl2-mixer-dev
[✓] Checking for libsdl2-ttf-dev
[✓] Checking for libportmidi-dev
[✓] Checking for libswscale-dev
[✓] Checking for libavformat-dev
[✓] Checking for libavcodec-dev
[✓] Checking for zlib1g-dev
[✓] Checking for libgstreamer1.0-dev
[✓] Checking for gstreamer1.0-plugins-base
[✓] Checking for gstreamer1.0-plugins-good

[i] Kivy Python library installation check (will be installed)
[i] Installing Kivy Python library…

Then it stops.

I ran the update and it didn’t change my .ini file and gave me the update needed message. I ran the update again and then it did update .ini file and everything seems to be working.