Weather34 template, block Dayligth Darkness no display data!

Greetings community of enthusiasts, recently I configured the weather34 template in a local server (NAS Synology) for testing purposes, the configuration in Meteobridge is fine, the information is updated without problems in the MariaDB 10 database, use PHP 7, Apache HTTP 2.4 and phpMyAdmin without any difficulty, I have also in test form another template “Meteotemplate” successfully.
The problem as you can see in the attached image is that the data block corresponding to “Dayligth Darkness” does not display any data for no apparent reason, I have tried several configurations of the template without solving this problem. :frowning:
Could some of this helpful community give me a clue that I need in my configuration to work properly.
Thank you very much for your time

weather34template HarMB APIwea

As Brian mentioned already, he does not support it anymore and sends to Wim for support

You can try in this forum

1 Like

meteobridge version is fully supported probably not inserted lat lon correctly @rhoos5 just pm the url and your setup password if server is publicly viewable,accessible ill take a look you can change password anytime you wish…if not just pm your lat lon i can test it locally …brian

edit just seen your pm just appear…also check you typed timezone correctly
php timezones

1 Like

Thank you very much Brian @Weather34 I really feel grateful. I made a cut-out of the Lat / Long settings, etc. so I can see it. The problem persists :frowning:
Question, you can do remote control by “TeamViewer” or some other means, my server is private, local network configured on a NAS Synology. If the answer is positive, I share my email so we can communicate privately.

Thanks Eric, for your information!

good morning

ok those checked out ok as from screenshot below so you need to look at local server config for support for timezone . failing all that zip up settings1.php and send it along i can test it locally…


Good morning Brian,
The configuration of my local server looks good, see the pic; I made the suggested changes and the result is still negative, there is no data in Daylight…Darkness. I copy the requested file, please change .txt !
Thanks again,

settings1.txt (2.2 KB)

your settings no change from file you sent just dropped in my local server setup no problems so you need to resolve at server level somewhere its not reading timezone !!!

screenshot attached san%20jose

Thanks Brian, some clue where I can check my settings, another template that I have in test works well and I’m not an expert in programming or PHP.

there is nothing to edit in template it is just standard php as you can see in screenshot using your settings1 .some time ago may be a year or so ago some one using nas synology had similar issues but it is so long ago i cant recall what the solution was but it was at server level and timezone keeps ringing a bell …personally instead of losing your mind best use the other template i cant be of much help unfortunately when it requires server level adjustments etc… ps try sun1.php option and also change hardware option to weatherflow unless your using davis hardware then its not the right forum …sorry couldnt resolve …brian

Thanks Brian, I know you like to help and sorry if I bother you a lot, one last option is if you can remote control my desktop with an application like TeamViewer, it would not have any problem in which you take a look at the configuration and learn together of the experience.
Thanks, again

hi its not a problem to bother me i dont see it like that but experience tells me when it comes to server level adjustments its something i would NOT have access to from here so there tends to be a lot to and throwing and throw in the time differences between us it can be a lengthy process(days) …team viewer i dont have anymore all i got is Skype but its now evening here and my best time when rest of house is at work is probably your early hours of the morning…

try the Core tab contains all the PHP ini settings and look for anything related to timezone .

  1. In the PHP Settings page, double-click on the desired PHP profile.
  2. Go to the Core tab.
  3. Find the ini setting that you want to edit. You can type the name into the search bar.
  4. Click on the value in the right column to edit it.
  5. Click OK to save settings.

Thanks Brian, I will check very carefully all the configuration in the server or PHP, and all your suggestions of time zone and soon I will be informing you.

One question. What is your station id?

1.- WU:

2.- WF:


Do you use Anerica/Central as your timezone?


dont you mean America/Central but that dont exists if am mistaken

To the point, on your server, what timezone did you set?

in the post above there is the screenshot of his server time .

That looks like it is from the Server OS. What did you tell the PHP server application? It’s PHP that is having the issue with the zimezone.

1 Like