Weather Station WordPress Plugin

wordpress

#1

Hello all!

As I just released Weather Station 3.5, I thought it was time to come and talk to you about it. So, here is the plugin I develop with love :heart:

Weather Station is a free and open source plugin that lets you collect, historicize and display data from weather stations right from your WordPress site. Initially, I wrote it to be able to make a small weather site for a Netatmo station using WordPress publishing power. But, after many feedbacks, I’ve extended the concept to many stations brands and publication methods (via APIs, files, etc.).

It is, since many months now, fully compatible with WeatherFlow Air and Sky and it supports indoor/outdoor location.

The “concept” is pretty simple: an engine collects data from stations you set; this data is stored in the WordPress database then data (from the database) is used to be displayed in pages or posts on the website.
Data can be displayed as texts, widgets, controls (gauges, lcd, meters, etc.), charts (lines, bars, candlesticks, radars, wind roses, etc.) and of course, it doesn’t require to know how to code to be used.

I’ve made a site to present the plugin:

If you want to directly jump to the showcase, it’s here:

Don’t hesitate to tell me how it can be improved (features, usability, etc.), I’m always listening feedbacks from users. And, as I know this community is full of strong enthusiasts, don’t hesitate too if you have technical questions… :wink:


Weather34 WF API version Discontinued
Smart Weather Station Third-Party Applications
#2

Pierre,

That’s so awesome and thanks for sharing! :+1::heart_eyes:


#3

Excellent work, my friend. It’s beautiful.


#4

Thanks @Phoenix & @GaryFunk :heart_eyes:


#5

i like it, not a lover of wordpress but if anyone asks me about wordpress then ill point them there


#6

This is a great feature for WeatherFlow. There are many add-on products.


#7

Nice job @pierre!!!

Now I have a reason to login to my WordPress account again (like @Weather34 I didn’t have much use for WordPress, but now it is worth another look).

Might get back to you to see how I might use your plugin with another instrument I am working on.

Thanks again for sharing with the WaetherFlow community!


#8

W hat version of worpress do u need. Free version or a higher version


#9

With great pleasure :wink:


#10

When I’m speaking of WordPress, I mean wordpress.org (the free community edition). You can do it with wordpress.com (same software, but payed maintenance and hosting) but I definitely recommend the free one if you have a place to host it.
For version, the requirements are WP 4.x and PHP>5.2, but if you have choice, choose the last version of WP, a PHP 7.x and activate auto updates, that’s the best combo :wink:


#11

What version of Wordpress do u need. The free version and or higher version


#12

I dont et dont think rhe free one uses plugins


#13

Free and paid versions are exactly same software with same features. The only difference is with the paid version you have hosting + backup + maintenance + some expensive plugins… Mine is free and works on the two versions :relaxed:


#14

I have the free version. Where are the plugins.
section. Cant find. Is there a difference between andriod and desktop wordpress


#15

I must admit that I’m not very comfortable with the English language (it’s not my mother tongue) and I’m afraid of not making myself understood. I suggest you look at these tutorials which are a good starting point to understand how to make a website with WordPress: http://www.wpbeginner.com/guides/


#16

You are doing well. Much better than I do with Vietnamese.


#17

Great stuff. Do you have an example site that uses this plugin with WeatherFlow that we can look at ? I see all the widgets etc. but a full-up site is always nice to see as an example of what ‘done’ might look like.


#18

YES I agree. CAN WE SEE IT


#19

How do u sr unit. Wordpress. Do u need the jigher level of wordpress


#20

Help. I have the free wordpress. I dont see any thing bout plugins. Where are the plugins. Do i have to have the higher version of wordpress