Update stalls at Kivy install (100% CPU)

How are you connecting to the Pi? Are you using an SSH connection?

Disregard - I spoke too soon. It just took a few minutes to start!

Yes - I am using SSH. All seems to be fine now. Thank you for all your effort, especially support!


Guess I did . . .but I really don’t know how. . .other than just running “stable” instead of “start”.
Subsequently ran as “start” . . . and console appears to be ‘stable’ at v23.3.1.

Had a slight difficulty with the SLP reading on ‘wfpiconcole’ vs that was indicated by the Tempest device. Per the thread entitled Barometer discrepancy. . .I followed the instructions you laid out in the middle paragraph. Seems like the parameters on ‘wfpiconsole’ (temp, wind speed/dir and SLP) are like a minute or so off from that of the Tempest device. I’m NOT an expert in this area. . .but seems the WebSocket is slightly delayed somewhere along the line. . .either to ‘wfpiconsole’ or the Tempest / Hub.

Please don’t do that until they have the supply chain fixed. :sweat_smile: I’ve been trying for 6 months to get a 4

1 Like

Tried the update on my Pi 3 and the kivy build fails. I had previously updated on or around February 6th of this year without issues.

ERROR: Failed building wheel for Kivy
Failed to build Kivy
ERROR: Could not build wheels for Kivy, which is required to install pyproject.toml-based projects

I tried the following command because I saw it in the thread…

python3 -m pip install kivy[base]==2.0.0

But this made no difference. Full install text is attached, looks like a bunch of kivy build errors and I know nothing about kivy.



(Attachment update.log is missing)

The attachment failed to upload. When the updater first runs, it should run a bunch of checks (architecture, OS, raspberry pi model etc.). Can you run the updater again and copy/paste the details of those checks here. That way I know exactly the combination of hardware/OS that you are using. Thanks

Yes, got the error message that it was not an approved file extension. Reattached and here is the list of checks…

$ wfpiconsole update

[✓] Root user check passed
[✓] Architecture check passed (armv7l)
[✓] OS check passed (Raspbian GNU/Linux 10 (buster))
[✓] Raspberry Pi check passed (Raspberry Pi 3 Model B Plus Rev 1.3)

update.txt (38.5 KB)

Ok I need to look into this as all the hardware checks out so it should install with no issues

Ok, I’ve tried two fresh installations this morning with your hardware (including with a brand new copy of Raspberry Pi OS on a spare SD card) and I cannot recreate the issue you are seeing. I would suggest starting with a clean copy of Raspberry Pi OS Buster on your SD card. That should fix the issue

Ok, thanks. I will give that a try.