Tempest UV sensor failing

I’ve already submitted this to customer support, but just in case there’s more information someone here can provide and/or there’s something I haven’t tried yet, I’ll post the info here.

I just put my Tempest up about a week ago. The first two days were pretty “rocky”. I would occasionally get one or more sensor failures, and occasionally it would stop sending updates. Each time, I was able to recover by rebooting the Tempest (which is not an easy task given it’s mounted on a pole up on my roof). I probably rebooted the Tempest at least 8 times in the first two days. RSSI between tempest and hub is good (typically between -45 and -50). RSSI between hub and wifi is good (typically between -50 annd -58). Battery level is good (hasn’t gone below 2.6V yet).

After about 2 days everything seemed to settle down. I don’t know if some (or all?) of that was due to sensor calibrations or what. Note that it might be good to note somewhere in the quickstart guide or somewhere else about these calibrations. I had no idea it did this until I started looking at forum posts.

Anyway, I finally had about a 36 hour period of no issues. Then I started getting a bunch of spikes in solar radiation. It was spiking to values as high as 50,000W/m2 (not a typo!), and this was happening between about 3am and 9am. I rebooted the Tempest and it seemed to be fine for a little while, but then it started reporting a UV sensor failure. This time no amount of rebooting the Tempest could fix it.

I tried the hub radio reset (didn’t expect this to help, but it was easier to try than going back up on the roof).

Then I tried following the directions in the troubleshooting guide to re-pair the tempest to the hub. My results didn’t quite match the directions, and didn’t resolve the issue. Here’s what I did and the results:

  • hold clear button on tempest until it started flashing
  • directions say after that it should flash green, but mine flashed red
  • I went into manage devices and clicked “+” to add. It found the tempest but said it was paired to another station and that I should delete it first.

I didn’t want to delete it, because I didn’t know what consequences that might have (and now reading the forum, I see that it’s probably good that I didn’t delete it). But it seems just the act of going in to add station re-paired to the hub and it started getting observation updates. But the UV sensor still reports a failure. I did this sequence twice with the same results each time.

It’s generally been running fine for the past several days, with the exception of the UV sensor. I’ve tried rebooting the Tempest once or twice a day to see if the sensor would eventually recover, but so far it hasn’t.

Any thoughts/suggestions?


That typically indicates a sensor failure.

Leave it up until you get a replacement so at least you have the other data and can do a Replace Device to keep the history linked.

BTW, you might want to put a link to your station in your profile so others can take a look at your data.

Thanks. I knew that a solid red indicated sensor failure (and that’s what I get when I press the button), but I didn’t know and/or wasn’t expecting that a flashing red light during the re-pairing phase would be due to a sensor error.

Added a link to my station on my profile, as well as my web page that has my webcams plus the weather station data ( http://pacificaview.net/livecam/sharp_triptych_wx.php )

1 Like

FWIW, this morning I noticed a new FW was pushed to my hub. I was on 143, now it’s 146. After the FW update both the UV and wind sensors were failing. They stayed that way until this morning when I went up and rebooted the Tempest. That brought the wind sensor back, but not the UV.

Man, they really need a way to reboot the Tempest without going up there and flipping the switch. That’s really onerous when it’s mounted high up on the roof.

People in this forum such as @GaryFunk can reboot it from their end. But I kind of agree there needs to be a reboot button in the app for the user so they don’t have to wait for someone here to do it.

Btw I haven’t got my Tempest yet here in Australia but I have been reading the forums to famillise myself with the device. And yeah I know it’s 1:30am here but lockdown has made me nocturnal lol

The only person able to reboot a device except Weatherflow staff is me :wink: Gary can’t.

Regarding an option to remotely reboot, I agree, it would help some (under the condition the device is still radio linked).

I did do the push in the hope it would solve a few thing but indeed your UV sensor seems nasty. Not much more we can do here. You’ll have to open a ticket with support that will replace it once confirmed.

Sorry again this happens but is will be solved.


Thanks for trying eric!

WeatherFlow support had sent me an email reply to my initial set of issues (updates stopping, periodic sensor failures, etc). In the email there was some verbiage about being able to re-open the issue by replying to the email. So I responded to the email several times with different updates and changes in behavior and things I’d tried, culminating with my last email indicating it seemed the UV sensor was completely toast.

That last email was sent about 4 days ago, and I haven’t heard back. I gather they’re pretty backed up with a pile of new Tempest owners. I can understand the delay in responding, I’m just wondering if it would be better to file a ticket, or whether the emails I sent should be sufficient and I should just keep waiting?