Tempest no longer joins with hub

My tempest had been working fine, with an uptime of over 300 days (nice!). Then maybe a week ago it restarted, possibly a firmware update - not sure - I stopped keeping track of the firmware numbers a while ago. A few days after that I noticed it was offline, so I went up on the roof and checked and it had a flashing red light, so I restarted it. It worked fine for 4 days, then this morning I noticed it was offline again.

I went up and looked and it was giving a slow flashing green, which I believe indicates it can’t connect to the hub. So I restarted it. That didn’t help. Then I did the radio reset on the hub, that didn’t help. The last status message from a few hours ago indicates the battery was good, the sensors were good and the RSSI was good.

I tried a few more times resetting the hub radio and restarting the tempest with no luck. I brought the Tempest inside and set it 3 feet away from the hub and then did a radio reset and restarted the tempest. It still doesn’t seem to want to join with my hub.

Hub status:

Last Status Message
04/07/2023 11:42:57 am
Wi-Fi Signal (RSSI)
Strong (-48)
Serial Number
Firmware Revision
Station ID
0d 0h 5m 52s

Tempest status:

Last Observation
04/07/2023 8:56:01 am
Device Signal (RSSI)
Good (-46)
Serial Number
Firmware Revision
Device ID
4d 23h 21m 5s
Battery Voltage
Good (2.66v)
Sensor Status

FWIW, weather flow support said to try going into the “replace device” menu. Just the act of going in there appears to have cleared up the problem.

1 Like

Yes, that is one trick that works great. You probably could have just done a long press on the LED button on the bottom of the Tempest and done the Replace Device thing and it would have worked. This has worked for me on both the original SKY and the Tempest.

1 Like