Station name on map is nearest street name not name in the settings

New Tempest station set up and located on the Google map. When I look on the station name shown is the nearest street name not the value I entered in the settings…

Welcome to the community @zero! Can you share your station ID with us so we can help further? When you changed the name of your station, did you press “Save” after making the changes to the name? Sometimes the Save button disappears off the bottom of the screen.

Close…wrong station but yes I had missed the Save button off the bottom of the screen. However, despite saving, a wait and refresh it is still showing the wrong name, even when looking from a different device.

You caught me! :sweat_smile: I didn’t realise the map just defaulted to the last station I looked at!

Interesting that even pressing the save button doesn’t work. I just tested it using the Android app for my station and that worked well. Can you share your station ID so I can see what it shows to me?

there are two places to set the name. One is the Station’s name, and the other is the name used for public data. I’ve set them both to the same :slight_smile:


Yes, just discovered the Public settings…which had defaulted to Station settings except it took the name from Google Maps. Now looking good.

Having retrieved a spare pole from the loft which I’d planned to use, I found the diameter was exactly 1"(25.4mm) - not the “standard “one-inch” nominal pole (outer diameter = 1.315 inches, or 33.4 mm)” - so final deployment will be delayed and I’ve gone off air as no-one wants the living room weather data!

Station is still on the map - is there a way to remove it or mark as in “maintenance” mode?


make it non-public would remove it from the map.


I thought that too but it was still updating. Anyway, turned Tempest and hub off and it’s now gone until I get the mast and deploy it.

Thanks for all the suggestions; there’s a lot of good information to discover in this community.