Station config issues on web: Opera/Linux and Edge/Win10 (Solved)

Using the web interface I’m seeing a couple of issues. First the elevation value is not displayed (or editable) from the manage station page:
no_elevation

Same thing if I go to manage a device. The Height above ground is not displayed or editable:
manage_air

Clicking on “Advanced” simply clears the fields and I have to use the browser back button to recover:
advanced

This happens with both the Opera browser and Edge browser on Windows 10 and the Opera browser on Linux

2 Likes

I’m using Chrome on Windows 10 and can edit Station and Device height.

I just tested this in Edge and I can edit the values.

5 Likes

The Sky battery card is displaying and seems correct.

I tried hiding and then unhiding the battery cards and the air battery card did display but then didn’t show any voltage value for the Air. After restarting the app or refreshing the web page, the Air battery card disappeared.

Air battery status does show in the device status page.

This is with with an iphone 8 with latest IOS and using the web interface.

1 Like

We’ve seen this in the past (not many times)

maybe let’s ask @WFmarketing if they can have a look under the hood and ‘push’ it back in place.

Not sure if this isn’t related to some server side caching … but that’s a wild guess

3 Likes

I merged both topics as to me the underlying problem is the same.

Let’s see what staff can find in your account that is messing with your options to edit …

You have not by any change any device linked via BLE to the hub (blue led) while editing online ??? I can imagine both situations to mangle … but again wild guess

3 Likes

The battery card issue exist on both the app and the web interface. The other issues are just with the web interface.

1 Like

Before I forget, could you share your station id ? That will help staff to locate it quicker for a solution.

2 Likes

The station ID is 4697, sorry I forgot that bit of info initially.

Thanks, @bpaauwe. I will take a look into the issues with editing the station’s elevation and the device’s height above ground and will post an update.

1 Like

Microsoft Edge has more bugs than me, and I’m a beekeeper with 35 hives. It’s a piece of junk, actually had it prohibiting the default admin user (the one you add when installing the OS) from running applications like calculator, IE, Office etc. There is a reg hack to deal with that issue but not sure it will work for this problem and it was pre the latest release. Opera surprises me, usually they are quite good. Something MS and Opera are doing different from Chrome, FF, Brave. Is Edge and Opera up to date? Latest Windows Updates installed?
I do have the battery card issue though, Malphone X, latest IOS version 11.4.1

1 Like

@bpaauwe Unfortunately, I have been unable to reproduce this issue.

I suspect that a JavaScript error is being thrown and that is causing the issues on the page. If you are up for it, can you send me a screenshot of the Console from the developer tools?

In Opera, you can find this information by going to Developer -> Developer Tools. Then clicking on Console. The Default levels of logging will show any JS errors.

Thanks for your help!

Yup, it is throwing a javascript error. This is for the station elevation:
station-0d7ecfbea5.min.js:2 Uncaught TypeError: Cannot read property ‘toUpperCase’ of undefined
at Object.t.DataDisplay.getNumberWithPrecisionAndUnits (station-0d7ecfbea5.min.js:2)
at n (station-0d7ecfbea5.min.js:1)
at Object.locationsLoaded (station-0d7ecfbea5.min.js:1)
at station-0d7ecfbea5.min.js:2
at Object.success (station-0d7ecfbea5.min.js:1)
at i (jquery.min.js:2)
at Object.fireWith [as resolveWith] (jquery.min.js:2)
at z (jquery.min.js:4)
at HTMLScriptElement.c (jquery.min.js:4)
at HTMLScriptElement.dispatch (jquery.min.js:3)

It does know the elevation as right above the error:

  1. location_meta:

  2. elevation:401.6106262207031

  3. share_with_wf:true

  4. share_with_wu:false

Just FYI, that javascript is very difficult to read :). Looks like it’s related to the “Other Units” setting. So I checked that and it was not set. Setting Other Units to imperial solves the issue for elevation and height above ground. It also solves the issue with the “Advanced” selections not working.

I don’t recall actually setting any of the units as I believe the defaults were OK. So maybe the issue is that the “Other Units” setting didn’t have a default?

1 Like

Great find, Bob! Maybe there should be default settings.

1 Like