Red LED - Hub not connected


I have been a happy owner for the past 2 years. About an hour ago I noticed the LED on the hub turn red. I was puzzled, but we were watching a movie so I didn’t want to fiddle with router and Wifi. After the movie I tried a power cycle, still red. I then tried rebooting my router, still red, then repeating the power cycle, still red. I then tried resetting the hub, rebooting the router, power cycling and shutting down the phone in various combinations to no avail. When I go into the app and go to setttings > stations and go to wifi setup i just get a message saying

‘Hub not connected, Make sure your HUB has power and is within 10 feet, you may need to restart the app or cycle the power on your HUB.’

So I did that still no life.
I can get the LED to switch to blue if I let my phone forget the bluetooth pairing and then re-pair with the hub, but it doesn’t change anything. After a power cycle/reset it remains red.

I am at a complete loss.

Do not pair your phone with the hub. Let the app take care of connecting, not the phone’s OS.

Once you have deleted the phone pairing to the hub, are you able to use the app and go into settings? LED should be blue at this time. If so, try setting up the Wi-Fi again. If the hub can’t find any Wi-Fi, try turning on the hotspot on your phone and see if the hub sees it. If so, connect the hub to the hotspot and save the setting. Exit the app and verify that the light on the hub turns green. If so, the hub is probably fine. Open the app, go back into settings and try changing back to your home Wi-Fi.

If this doesn’t work, try a different powersupply on the hub. It draws very little power so just about any phone charger should work. If that doesn’t work, check to see if your router had a firmware upgrade, maybe some setting changed. Remember that the hub only has a 2.4GHz radio.

Hi, thanks for helping out!

As soon as I unpair the phone the LED is back to red. I can access the app and go into settings but when i try to acces WIFI setup i get the aforementioned error message.

I’ve tried other power supplies as well since this was also mentioned in the troubleshooting but it didn’t help. The router firmware can only be updated manually updates, so that¨s not the problem.

One thing I have noticed since yesterday and which is puzzling is the weather summary when opening the app seems to change whenever I open the app, but when I tap the weather station icon to see the detailed readings, the same numbers as yesterday appear every time without changing.
The weather summary only updates when the app is loaded after being completely shut down.

I think the "Hub not connected … " message means that your app is not connected to Bluetooth since that is what the app uses to connect to the hub. If you are seeing that message when you have a blue light on the hub, that usualy means something else than the app you are looking at is connecting to the hub via Bluetooth. If the app cannot connect to the hub, the app does try to connect to the Tempest servers on the internet, so, the data you see are from the last time your station sent data to those servers.

I am thinking a step by step approach may be worth trying …

1 - Try the steps at just to make sure you can get a good Bluetooth connection between the hub and the app on your device.

2 - Since the red light means the hub is not getting connected to anything (either Wifi or Bluetooth), anything you do via the app is talking to the Tempest servers on the internet. So, once you get a connection to Bluetooth, try all the steps at , Make sure you have the blue light on the hub when you are doing these steps. If the red light is on, your app is not talking to the hub and changes to the wifi setup can’t be done.

If things still are not working, I would recommed opening a support ticket.

I tried option 1 without any luck. Then, on a whim, I tried reinstalling the app and then it connected instantly without pairing. Now I could access wifi and we’re online again.

Thx everyone for your help