PiConsole Screen Saver no longer working

I have two piconsoles. Both of them no longer have the screen blanking after a set time.

Previously, this worked with the following line in lightdm.conf

xserver-command=X -s 240 -dpms

After four hours the screen with go blank as expected.

Not sure what changed.

PI Info: (Both the same)
Raspberry Pi 4 Model B Rev 1.4

Is there anything I can provide or try to remedy this?

Confused. What does piconsole have to do with a Xwindows windows manager setting ?

I don’t understand your question.

Are you confused about lightdm, piconsole, a setting in lightdm.conf to enable the screen saver or the fact that is stopped working a month ago?

How can I explain better?

You haven’t described your setup at all, but you seem to be asking a “how do I make Xwindows work” in a forum that has nothing to do with Xwindows.

We’ll, that’s not the case but OK. Maybe someone else can help, I appreciate you chiming in, but maybe this one you can skip?

Setup:

Raspberry Pi 4 Model B Rev 1.4
Kernel: 6.1.13-v8+ #1632 SMP PREEMPT Thu Feb 23 12:26:19 GMT 2023 aarch64 GNU/Linux
Tempest Version: v22.12.3
Debian GNU/Linux 11 (bullseye)
DE: Light Display Manager 1.26.0

Touchscreen:
Raspberry Pi 7" Touch Screen Display

So…
Does anyone else have screen saving working, because about a month ago, it stopped working on the PIConsole. My PIConsole touchscreen now ignores any sleep or screen saver settings.

What @vinceskahan is trying to say is that the issues you are facing are very unlikely to be caused by the PiConsole, and rather are likely related to some change/update that has been made to your Raspberry Pi itself (probably through an update). I have no knowledge of xserver commands so you might want to ask elsewhere for help

Yes I got the point. That back and forth with him was painful.

I was more looking for someone to say “Yes, I am also experiencing that”.

But yes, I’ve tested without piconsole running with the same outcome.

For any poor soul with this issue:

https://forums.raspberrypi.com/viewtopic.php?t=323281&sid=321dd4adb5767af2b253f734138c8c8c&start=1025

2 Likes

We love you too. Thank you so much. It’s unfortunate you are so sensitive.

I was suggesting you should ask in the appropriate site for such questions. PiConsole doesn’t even ‘use’ Xwindows so what you described ‘had’ to be unrelated and an os issue that you should ask in an os forum (not here).

The WF forums can’t be expected to duplicate 20+ years of the entire Internet. Google it for heaven’s sake.

Consider taking your original question and rewording it just slightly…

I have two cars. Both of them no longer have bluetooth working.
Previously, this worked by pressing the button on the display.
Not sure what changed.

Car info: Toyota Corolla (Both the same)
Model year 2020

Is there anything I can provide or try to remedy this?

Now in that case would you really expect somebody here to say anything other than ‘you might want to ask on a Toyota users site’ ???

C’mon man.

1 Like

you’re great Vince. Thanks for being great

My Piconsole’s screen no longer goes to sleep after 5 minutes either after running pi updates as well as the latest piconsole update this morning. I am unconcerned.
Jim

Hello, Jim, and welcome to the thread.

Are you running bullseye on your Pi ?

I am and what worked for me was downgrading xorg-server-core by doing the following:

See all available versions

apt list -a xserver-xorg-core

Listing… Done
xserver-xorg-core/stable 2:1.20.11-1+rpt1+deb11u5 arm64 [upgradable from: 2:1.20.11-1+deb11u5]
xserver-xorg-core/stable-security,now 2:1.20.11-1+deb11u5 arm64 [installed,upgradable to: 2:1.20.11-1+rpt1+deb11u5]
xserver-xorg-core/stable 2:1.20.11-1+deb11u3 arm64
xserver-xorg-core/stable 2:1.20.11-1+rpt1+deb11u5 armhf
xserver-xorg-core/stable-security 2:1.20.11-1+deb11u5 armhf
xserver-xorg-core/stable 2:1.20.11-1+deb11u3 armhf

Install previous version

apt install xserver-xorg-core=2:1.20.11-1+deb11u5
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
xserver-xorg-core is already the newest version (2:1.20.11-1+deb11u5).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Avoid upgrades for the time being (already done for me)

apt-mark hold xserver-xorg-core

Thanks so much for this … after the last update - which forced me to rebuild from scratch both of my Rpi wfpiconsole systems, I lost the ability to blank the screen at night.

I had a cron task switch between day & night - allowing me to make dark the screen while no one was awake to see it.

Followed your instructions, and ALL is back to the way it was.

Edit: It would be a nice feature for Peter to add within the ‘Settings’ to have screen active/blanking schedule.

Glad to help.

I hope other’s in this thread take this interaction as a lesson in the future. It’s OK to help each outside of the boundaries of PiConsole since everything interacts together in some way.

Glad it worked for you !