Older "SKY" Won't Pair to New Tempest Hub

I just received a new Tempest to add to my older Sky. Plus, I needed a new Hub anyway as my older Sky Hub was being grumpy. The new Hub and Tempest installed perfectly. In trying to re-add my deleted Sky to the new hub, I can’t get it to pair. Either with the solar attachment or batteries, the “clear” button - window will blink softly blue but won’t go to the pairing green. I have held the clear button multiple times in different ways and it just stays in soft blue blinking. Ideas?

You say you tried to push the button in several ways but did you try a long push on the led till it blinks (might take a good 10 seconds before this happens)

Yes, multiple types of long pushes. 10 seconds, 20 seconds, longer. The button clearly depressed but the light never changed.

right, digged in old posts to see if there were some other ‘tricks’

reset it via a long push on the led, after that open the battery lid and leave it there for at least a minute to be sure the circuit drains fully. (so no solar panel attached neither)

Close the battery lid and try to pair it once more.

If this fails, once we got someone out of this by asking to un install the app, reboot his phone, re install the app and log in again (you won’t loose your station, just use the same logins and you’ll find it the way you left it)
Then do above over again.

If this fails … I’m out of ideas and must ask you to contact support via the ticketing system …

Maybe another @tech-gurus has some other ideas ??

I just tested the button on a used SKY I just received. I installed an SPA and then used the handle of a fork to press the button. I felt it press in and held it for 20 seconds or more and nothing happened. When I turned the fork around, so the angled end of the handle pressed on another location on the button, the button began the pairing blink in less than 10 sec. Try pressing on the button in different locations? Maybe that is what you did when you wrote…

When you say the light is a soft blue, is it purple maybe, as described here: https://help.weatherflow.com/hc/en-us/articles/115005229827-Troubleshooting-Guide-for-Smart-Weather-Stations#AIR/SKY

Here is what the push button switch looks like. The switch is on the right side when viewed in this picture. The plunger of the switch itself is a dark rectangle. The opaque plastic has a small extension that presses down onto the switch. The switch has a tiny click when it operates. The long extension on the opaque plastic is to refract the light from the led.



This picture shows the opaque plastic small extension resting on the dark rectangle which is the switch.

cheers Ian :slight_smile:

1 Like

What is the firmware on the Sky?

Since I can’t pair the device and get it operating, I can’t see the firmware version. But I’ve not updated since I have had it. SN # 8708.

To other respondents, I’ve tried your suggestions without success. I especially appreciated the detailed photos of the operation. I tried different types and positions of presses on the acrylic button. The slow blinking purple light never changes. Listening carefully, I don’t hear the “click” either. It seems somehow the hardware has lost its reconciliation of the plastic acrylic button cover with the button, and no variation of attempt makes a difference.

It may be time to open a ticket with support. I assume the AIR paired just fine?

Yup, I think you are right. The “Air” paired fine, and the new “Tempest” paired fine.

I transfered my AIR to an indoor device and paired it with one of my Tempest Hubs. No issue during the pairing process with AIR. Very well could be a problem with your SKY as suggested.