My device ID doesn't work?

Hello, I am new to the tempest community and this project as a whole.

I am attempting to use the wfpiconsole “off label” on a windows 11 machine. I followed the amazing instructions on the GitHub page and it all went smoothly until I got to what should have been incredibly simple… the device ID.

I then tried a suggestion I saw in another post to add my information to this URL.
Which gave me a good response from the station.

Any ideas on what I could possibly be missing? All feedback is appreciated.

**I apologize for the blurred information in the images. I was unsure if the station API key would be considered “sensitive” information.

Hi, sorry you are running into issues. I think there might be some confusion between your station ID and device ID. When I try polling the API with your station ID (103412) I get a different response to what you have shared.

Can you open the Tempest app on your phone/web, click on SettingsStations[your station name]Status. Under the Hub title you should see the Station ID (sandwiched between Firmware Revision and Uptime). Can you share that with me? Scroll down a little further and under the Tempest title you should see Device ID (again sandwiched between Firmware Revision and Uptime). Can you share that with me too?

GLADLY!!! Screenshots attached.

Fwiw, I tried the station ID, device ID, and various iterations of the serial numbers too, but with the same result.

Curious, can you see my publicly shared page?

Thank you for your help!


Thanks! In a private message could you share you WF Access Token with me? This will allow me to use your station data while I work out what is wrong. Once I have finished, feel free to delete the key and generate a new one

Random words to make this post 20 characters long… :laughing:

PM sent!

1 Like

OK, thanks for the PM. Can you let me know exactly what error you are seeing? Using the token you shared, a station ID of 103412 and a device ID of 264028 works perfectly for me

Back at the first post I explain that I am using wfpiconsole “off label” on a Windows 11 machine. When running anaconda, I enter python and start the script. When it gets to the station ID it doesn’t recognize my station and then questions my sanity. The screenshot is up there. ^

I see that screenshot, but there is no error. You have entered your station ID (there is then some additional debug information printed to the terminal which can be ignored - I’m not sure why it is printing this anyway), and then it is prompting you for whether you have a Tempest device or not. This is working exactly as expected. Have you answered ‘Y’ to the prompt regarding whether you have a Tempest?

I develop the PiConsole exclusively on Windows and Anaconda, so it should work perfectly

*sigh I am the error. :frowning:

I was entering the station ID and when it asked if I owned a tempest I was assuming it didn’t recognize that ID. When I entered yes and it asked me for the device ID I assumed it was asking for my station ID again.

Error: me not reading what was on the screen.

It now works perfectly. Thank you for developing an awesome application, and your support in this community.


No problem! Glad we managed to get it fixed :smiley:

Feel free to delete the WF access token you shared with me. You’ll just need to copy the new one into the wfpiconsole.ini file