Lightning strikes: Sensor vs. App

I’ve been watching the data from my Tempest since I got it set up in June, and one thing I’ve noticed is that it’s never reported a lightning strike of its own. Not once. As I type this, there are t-storms in the area, and I’m seeing plenty of lightning activity in the app, but still my own Tempest sensor shows zero strikes. I know this because I capture all observations broadcast by the hub, and when I query the lightning strike count over the last four hours, I get zero.

Has anyone else seen this behavior? Here’s what the app reports:

Maybe this topic will answer your question: Lightning reports (tempest).

I read that exchange some time back, and what I got out of it was this: The Tempest will report local strike events, but the derived/enriched data comes from the WF servers. The way I interpret that is I should see the occasional evt_strike event type come through in the UDP stream, and corresponding obs_st events with lightning strike counts, distance, etc. But I don’t. I’ve been recording data for a month now, with the usual periodic summer thunderstorms, and my Tempest device has reported zero lightning activity.

1 Like

The sensor status is OK on your station so not sure what is up. I did get out of that thread that a siting issue could be at play.

Ok this is going to be a dumb question, but are you 100% sure that you are parsing the correct field in the UDP data? It seems very peculiar that you are getting 1000s of strikes, but not a single one is detected by your station.

If you can move your station around during the next storm as per @gizmoev suggestion that would be worthwhile to see if the local detection changes. Otherwise, I would be tempted to open a support ticket and reference this thread. Be patient with support, however, as they are very very busy!

That’s actually a very good question, and probably one of the first ones anyone familiar with data parsing would ask. But yes, I’m parsing the correct fields. I double checked by looking at the raw JSON events and verifying that they were all zeroes.

I’d prefer not to move the station around if I can avoid it, but I’m wondering about grounding the pole. The steel pole it’s mounted on is secured to a fence post with U-bolts, and not sunk into the ground. Not sure what that might do, if anything at all.

I can state with 100% certainty that was the case here for my station here. Ok, it might have heard one or two, I’d have to look at my original post in the beta tester forums. They were rumbling in the distance, cracking overhead, and striking with visible flashes in every direction here that day for a few hours. A big’ol old fashioned summer lightning storm in every sense of the words.

Interesting! Do you know how much capability the Tempest has to suppress lightning detections before they reach the WF servers? Assuming the sensors aren’t defective, surely their sensitivity has been turned down too much.

Poke around the forums for @dsj’s explanation of how lightning readings are synthesized in the app with your readings locally being only a small part of what the WF app reports for your location. They don’t release information about how they determine what your station might display in the ‘app’.

But regardless, your lightning sensor UDP will never remotely match what the App displays. This is probably the place where there’s the most secret sauce, other than the weather forecast part I guess.

I guess the only thing left is to wait for the next time we’re at ground zero for a good t-storm and see what I get off the wire. If I get zero lightning events again, I’ll open a support ticket.

1 Like

There was mention of a bug in the firmware here:

1 Like

I’ve got the 134 revision of the firmware, which I believe fixes this bug, which was causing a number of lightning sensor failures. Those failures no longer appear on my Tempest, but I still don’t see any lightning detection originating from my Tempest.

Yes, please do. We have some knobs to turn to adjust the sensitivity of your lightning sensor. But it’s also possible your lightning sensor is a bad apple (even if it’s reporting good).

1 Like