Issue with the Tempest IOS App Not Updating

Tempest App for IOS

In the past I could leave the Tempest app open for hours or days on a display IPAD and it would update consistently.

Starting about a month ago after a half hour or so the app no longer updates for digital read out values however the wind bar still changes

I then have to reload the app to get it to work again and the it fails again after a half hour or so

This is on the detailed view

I have also noticed this when pulling my station or a neighbors station up in the webpage view

I if course have the latest version of the Tempest App

Is this a known issue that is being fixed or do I need to open a ticket?

@cmorello as goes the song, one for you, one for… you :grin:

Eric is that to say it is a known issue?

Thank you

So it sounds like it’s not just an issue with iOS, but also the web app?
The websocket might be closing for some reason which is an issue we have been tracking. I haven’t seen it close that quickly/consistently though.

Is your connection changing at all and is this on Wifi or Cellular?

1 Like

It is on Wi-Fi and also happens in the webpage on symettrical 1gb fiber at home and at work on a corporate network

Hoping this can be fixed as it makes the app almost worthless having to reload it or refresh a webpage to get the latest reading

I had this problem a year or so ago, then the problem disappeared and the app has been stable since. However, just over the last few days, the problem has reappeared. Has the app been ‘updated’?

I did some monitoring the morning.

Both the IOS Application and the web interface both fail after 5’ to 7’ and stop updating.