iOS app v5.06 (655) Table view no data

After updating to the latest version, v5.06 (655), the first page looks fine with all the data and the forecasts, then I tap on the upper section and this is what I get for the table view. I have to completely close the app and re-launch it, sometimes 2 or 3 times, before I see data on that screen and then it works fine. It did not do this on the previous version. I tried deleting the app and associated data and re-downloaded, installed and set it up again. Still does the same thing.

This is on an iPhone SE 2020 edition. It works fine on my iPad Air gen 5.

@cmorello, this might be one for you.

I would try using the drop down at the top and reselecting your station.

I’ve seen this happen before, it’s on my radar for the follow up bug fix release.

1 Like

Thanks for the suggestion. I tried it and the issue still exists.

I did completely remove the app and deleted the data when prompted. Then downloaded and reinstalled the app and ran through the initial setup. This did not fix it either. The phone is running iOS 16.3.1

Have you cheked in the general settings the app can use data ?

The first screen shows the live data, the second table screen does not, therefore, the app is getting the data.

Everything for the app is turned on in app settings, just like it was before the update and just like it is on the ipad. It worked fine before the app update, it doesn’t work now, nothing else has changed, therefore… the problem is the new version of the app. This is basic troubleshooting logic. I should know, I have been doing end user support for well over 30 years.

This is what I get when I everytime I launch the app.

This is what I get more often than not when I switch to the table view.

It works every time in the web browser on the iphone and all other devices. It works every time in the app on the ipad. It ONLY fails on the iphone in the new version of the app.

Ok, so here I am, back after yesterday’s frustrated rant with hat in hand and feeling stupid.

After going on about all my experience in IT end user support, most of which is on PCs… I got thinking about the troubleshooting process and realized I never did the very first step you should always do, namely, cold boot the computer. I tend to forget that iPhones and iPads are never really off and there is no practical way to unplug the battery, short of disassembling the device, to ensure a full off state to completely clear the memory. So, last night I performed a hard reset with the button sequence of volume up, volume down and hold the power button until it cycles off and back on again. After doing this the app is working properly now. I have tested it many times since hard booting last night and it is working correctly.

Again, sorry for the frustrated rant.


Interesting. I wonder what was failing in the system side that was causing observations not to be received. Probably some network stack issue with the websocket.

At any rate, I’m glad it is fixed for you now. Please let me know if it returns and I can see about getting a debug build to you in order to see what is failing under the hood.

Will do! Thanks for the response.

I have now installed v5.07 (658) on both the iPhone and iPad. Both “i” devices are fully up to date on the OSes and all apps.

I am still seeing the issue on iPhone, but not as often. I have also seen it on the iPad but very infrequently. I’m not really wanting to install a debug build on these devices. I depend heavily on them for work and personal needs.

Can confirm I also had problems with previous build not sending rain or lightning alerts so I updated to the latest version and now the app crashes before it gets loaded on the forecast homepage.
The Android version on the other hand works flawlessly on a old Samsung GalaxyS7.


@tweatherman1 - Have you tried a full power off and back on reboot of the device? Is your iPhone/iPad updated to the current OS version? Have you tried deleting the app and, when prompted, deleting the app data from your iPhone/iPad, then download the app again, let it install and set it back up?

Regardless if the phone is on the latest iOS version doesn’t matter if its a available for my flavor of iPhone in the app store. I have deleted and did another install with same results. Like I said the latest Android app release works flawlessly on a old Samsung GalaxyS7.


All computers can experience corrupted system files. I have been doing end user support for more than 30 years and have seen it in all OSes. Computers and the OSes they run are creations of man and man is not perfect, neither are his creations. Doing an update to the OS is the easiest way to correct file corruption. A good OS installer app will check for and correct corrupt system files it is handling.

My OS is not corrupt. Every app on my iPhone works as intended except the Tempest app. This is the only app I’ve seen crash this bad on Apple or Android.


@tweatherman1 What model phone and iOS version are you on?

I will take a look at the crash logs and see if I can find one that matches. There aren’t that many right now for the latest build so I should be able to track it down.

Also do you have Analytics turned on in the iOS privacy settings? Unfortunately without that on the crash logs don’t propagate up to me.

Looks like this might be an Apple/Xcode problem.

What I can do is upload the app with an earlier version of Xcode and see if that takes care of it. Would you be willing to join a Testflight build? I asked CS to reach out to you about this so just let them know and I will get an invite sent to you.

I’m willing to try anything at this point to get the app to work again.


I sent you a PM. Let me know and I will get you added to the test build.

EDIT: A co-worker that has an iOS 13 device confirm it is crashing for them as well. The fix of building with an older Xcode seems to work so I will push that build out. Apple reviews can range from a couple hours to a couple days so if you want a working app now, let me know your Apple ID via PM and I can add you to the test build.

Update is rolling out now that should fix the issue for any iOS 13 users.