iOS Android - WeatherFlow Smart Weather "Settings" Crash (version 2.5 of App)


#1

Hi there,

The last update has introduced a bug. Version 2.5 of the iOS app crashes immediately when you attempt to access the application settings (gear icon). I tried deleting and reinstalling the app however that did not help.

App Version 2.5.0

iOS 12.1.1

PS - I do not have this issue on the Android version of the App.

Regards,

Ron


App crashing on iOS 12.1.3 on iPhone XS (new problem today, before update)
App windspeed continuesly goes back to Mph
#2

Hello Ron

I have version 2.5 (193) and it works ok on my iPhone 7 with iOS 12.1.3Ăź

You tried a reboot of the iPhone after swiping closing the app ? Or a warm (soft) reset ?


#3

Hi Eric,

I should have mentioned that I tried a reboot of my iPad (not iPhone) in my 1st message. Unfortunately, rebooting the iPad didn’t help. The app crashes immediately upon tying to access the settings. Please let me know if there is anything else you’d like me to try.

Ron


#4

try a soft reset, this forces the device to empty all caches remaining (even a reboot doesn’t clean them)


#5

Soft reset complete - same result as a hard reboot. App still crashes upon trying to access settings. Deleting the app empties all caches too and that didn’t solve anything either.

I tried a second iPad and it has the same problem. This iPad is still on iOS 12.1 (I had not yet applied the 12.1.1 update). I do not have an iPhone available to test.

At this point the problem appears to be an iPad running iOS 12.1 or later and Smart Weather app version 2.5.


#6

hopefully the crash report will help de the devs, not sure what it coud be as I haven’t problems

You have enough space left on your device ???


#7

Tens of GB of available space on both iPads.


#8

Of note - I have a very old iPad 2 as well (a 3rd iPad running iOS 9.3.5). It had not been updated to Weather Flow 2.5. Prior to the update it was working fine. After the update to version 2.5 of the app it crashes now as well when I try to access the Settings.

I believe I have another data point. I have my wind speed to set to KM/H. After the update to I noticed that it switched to MPH (without any changes on my behalf). I’m now wondering if this bug only appears if wind speed is set to KM/H in the setting (prior to the update).

Ron


#9

Hi There,

I have found the bug. Here are the steps to reproduce. It appears the the development team changed the approach to change the units of measure for wind speed between Android and iOS. In the Android app when you tap on the Wind Speed in Settings a modal pops up with a menu (radio buttons) of units of measure to select.

In iOS tapping on the wind speed (while in the Settings) cycles you through the list of supported units of measure for wind speed (there is no menu / modal popup to select a unit of measure in).

The Weather Flow app v2.5 update defaults wind speed to MPH (potentially only if you had KM/H selected prior to updating the app to v2.5 - I was unable to test that).

Step 1 - Change the wind speed unit of measure in Android to KM/H
Step 2 - Close the app and have it restart
Step 3 - Try to open the Settings in version v2.5 of the App in iOS (app will crash)

To Stop the Crashing
Step 1 - Change the unit of measure in Android to MPH
Step 2 - Open the Settings in version v2.5 of the App in iOS. The app WILL NOT crash and you can set the unit of measure of wind speed to KM/H.
Step 3 - The Android app will not synchronize to KM/H (and will continue to display MPH). The app used synchronize it’s settings across iOS and Android. If you change the setting in Android is will cause the iOS app to crash.

This problem seems to be isolated to Wind Speed from my testing. Upon further testing ALL unit of measure changes in Wind Speed (EXCEPT KM/H) work properly and propagate between iOS and Android apps

PS - I did not try all of the settings. By way of a test I tried to change the temperature unit of measure between C and F on both Android and iOS and it worked as expected. I could adjust that unit of measure on either Android or iOS and the change would propagate across all devices regardless of whether they were iOS or Android.


#10

this is something very useful for @wfsupport and @dsj

thanks for debugging


#11

You’re welcome. I’m Engagement Director / VP for a Digital Agency. I have teams of people that develop software and I still do testing for the team from time to time. :slight_smile:


#12

Bonjour, nouvelle version IOS, j’ai plus accés aux paramètres de l’application avec iPhone X ?

Pour vous aussi ?
Salutations
Mathieu


iOS App release v2.07
#13

Bonjour Mathieu

iOS vient de passer en 12.1.3 ce soir. Perso j’ai testé en version beta depuis un bon moment déjà et l’app de WF marche nickel.

As-tu la dernière version de l’app (2.5 ?)

sinon efface l’appli reboot et re installe.


#14

Bonjour, depuis la mise à jour 2.5 j’ai les valeurs de vent en mph au lieu de km/h et dès que je clique sur paramètres, l’application se ferme. Oui j’ai déjà fait un reboot deux fois… :face_with_raised_eyebrow:

Le mar. 22 janv. 2019 Ă  19:08, Eric via WeatherFlow Smart Weather sws@discoursemail.com a Ă©crit :


#15

c’est un bug remonté, tu peux y remédier pour l’instant via la page internet de ta station.
Tu mets en métrique via la page et ton iPhone suivra à priori. Ce qui est bizarre, moi j’ai pas ce soucis


#16

Merci bien ! :blush: tu possèdes une station en France ?

Le mar. 22 janv. 2019 Ă  19:24, Eric via WeatherFlow Smart Weather sws@discoursemail.com a Ă©crit :


#17

oui, sud de Toulouse


#18

Yeah, what he said. :wink:


#19

sorry for all the french but he needed some help as he has the bug related to latest app version (mph versus km/h)

and we live not to far from each other. Guess a foreign language section might become handy.


#20

You don’t need to apologize. I glad you are here and able to help.

Just wait till I start writing Vietnamese.