Interim firmware update: v49

Yesterday, we released a new Hub firmware build: v49. This is an interim release that adds a single feature: the ability to upgrade to a forthcoming major release. Owners should notice no difference in functionality whatsoever, but please report any anomalies you find here.

We will be rolling out the major release to field testers today. If all goes well, we’ll roll it out to the rest of the network early next week.

11 Likes

A post was merged into an existing topic: Hub Firmware revision 49 & 70

Awesome. Looking forward to it here in Canada.

Does firmware update automatically? How can I check the Hub firmware v?

In a web browser you can select the green LED at the bottom of the page. In the iOS smart application you can select the top left white gear / cog. Station-> Choose Station if you have more than one -> Status

1 Like

Touch on the Gear in the Top Left of the application.
Touch on Stations.
Touch the Staiton.
The bottom line, above Save, Touch Online.
Forth line down: Firmware Revision.

2 Likes

That worked… thanks… v49 for hubs

v49 for me too. Don’t remember the page with chengelogs. Someone has it?

First entry in this thread:

1 Like

Hi guys,
I have noticed my hub has updated but both my devices keep dropping offline all the time now, My hub has constant connection but Sky and Air are both offline. This seems to have coincided with the hub firmware update?
My station is at
https://smartweather.weatherflow.com/settings/station/3206/status
Any input would be appreciated.

Also i notice when if it comes back online there are huge gaps in the data, i thought the hub and sky/air were able to store the data and then when a connection came back online fill in the gaps, im not seeing this happen when looking at my graphs. Is this a bug with the firmware? If so when do us plebs (ie not field testers) get the new firmware.
Cheers

something odd is going on with your AIR & SKY connections. Please open a ticket (support@weatherflow.com) and they can help you troubleshoot.

1 Like

I have the same problem the hub is connected to the WFi, but the sky and air drop out and I am really not the far from where they are sited. I move the hub and often it starts working for a while but then the problems return. How did you resolve your issue? Thanks

What us the firmware on each device and what are the RSSI values for each?

Hub Firmware 98 RSSI -60
Sky Firmware 43 RSSI -82
Air Firmware 20 RSSI -102

Ouch. The Air and Sky RSSI values should be higher than -80. Move the Hub to area and try to raise it to -70.

1 Like