HUB Firmware v47


#1

All HUBs currently online have been auto-magically upgraded to firmware v47 to support a range of new features.


#2

You’ve forgotten to upload the release notes about these new features :wink:

https://weatherflow.github.io/SmartWeather/releases/firmware.html


#3

@dave Ya, you can tell our app developers have been working dbl time when they don’t update the public release notes. Ha! :wink:


#4

I try to update to this firmware using the android 2.0 app (galaxy s7) but it always says “failed to upgrade firmware please try again” the firmware is stuck on version 17


#5

David @dsj may have to do some work on the server end.


#6

@wadegrandoni Is you station ONLINE? If it is not online, it cannot connect to our servers to download the new firmware.

If yes, what is your station ID?


#7

Thanks @WFstaff , yes it is online but still not accepting a firmware update when I try it through the android app or going to get it on its own. The station id is 3877.


#8

Hi Wade. Yes, it looks like you’re one of a handful of Hubs stubbornly stuck on v17. Our system has attempted to upgrade you many times (297 as of right now) automagically, to no avail. There is a known issue in v17 (fixed in later versions) that can make it difficult to upgrade over certain network connections. This can often be fixed by simply switching to a different WiFi access point - temporarily - just long enough to perform the firmware upgrade. If you can use your phone as a WiFi hotspot, that’s probably the simplest and easiest way to make it work.

Please give that a try, if possible, and let us know how it goes. Worst case, we’ll need to send you a new Hub.


#9

That worked! I notice a lot of rainfall and higher wind speed than my hand meter measured (right beside) readings. I have it on a 10 ft steel pole that probably is resonating. I’ll try the pipe inside a pvc pipe encased in sand next to see if that helps.

Thanks.


#10

Follow-up - guy wires, steel pipe encased in pvc, both with sand seems to have helped. Accurate wind and no false rain with up to 60km/hr wind.


#11

Where can I look to find my current version?


#12

online where you see your weatherstation (click ‘online’ down the page)
it’ll flip over and give you loads of info :wink:

https://smartweather.weatherflow.com/settings/station/xxxx/status

change the x with your station number


#13

Hub is showing uptime as just 15 hrs so I guess it updated during the night ? Sky and Air both running longer in terms of hours.


#14

How can I update?
Why is sky higher rain fall as my rain gauge?


#15

Search in forum. There are plenty of posts about rainfall errors. Evidently work is being done to address the fact that “specific installation conditions can have a significant effect on the rain sensor calibration”.


#16

Received my SKY/AIR package and followed all instructions. Mounted SKY 16ft up on a mast. All went well, receiving all data except rain measurements. We had a rain squall come through and dumped a measurable amount of rain however, sensor didn’t measure anything but zeros. My SKY firmware is v43, AIR is v20. Could use some help if I did something wrong. Thanks.


#17

HI @dcwalmsley - please drop a note regarding your lack of rain to support@weatherflow.com and we can help troubleshoot with your directly. You may need a replacement unit.


#18

Hi team,

Just installed mine 2 days ago. Noticed that hub firmware is still v37. My hub ID is 4404. Can you guys check?

Many thanks,
Dragos


#19

Hello Dragos. We just upgraded you to HUB fw v47. Going forward, all HUB firmware updates will be automatically applied over-the-air. Cheers! - the WF team.

https://smartweather.weatherflow.com/settings/station/4404/status


#20

THANK YOU folks for the quick replacement unit. I am so pleased and excited to see the weather in my backyard and I’m injecting it into Weather Underground’s website! You guys Rock!