Configuration error


This was my 1st install of WeatherFlow PiConsole I have tried.

I d/led your code and received the same error, stupidly I did not look at the first version but it appears that it already was the v23.3.1. I then followed your instructions:

wfpiconsole stop & wfpiconsole update. It appeared to update with no errors and ended with the correct version of v23.3.1.

If the last fix was on March 3, is there something else I need to do?

The build is Raspberry Pi OS Legacy is Debian (Buster) of 2021/02/21 on two-year-old Pi 3B+ rev 1.3

Michael Sullivan

Sorry you’re having issues. Just to confirm, are you seeing

Error: unable to fetch station metadata

when you try and run the console?

Have you been able to successfully complete the configuration wizard when you start the console for the first time?

Thanks for the quick response! No I get the following, I’ve tried starting and stopping, installing & updating

“Access not authorized. Please re-enter your CheckWX API key*:” after entering WeatherFlow Personal API Key.

Sorry, yest I did get thru a configuration and the fail occurred after I entered my WeatherFlow API

Are you sure you are entering the correct key in the correct place? You say that you get the error after entering your WeatherFlow Personal API key, but the error is occurring when the console is asking for your CheckWX API key. If you are entering a WeatherFlow Personal API key in place of a CheckWX API key, then you will see this error