Amazon Alexa: Always Gives General Weather

Notice today when asking Alexa what the temperature was she replied back with the local weather forecast?!?

Is the service down or is this related to the HUB v.3X release?

Just checked and Alexa works fine giving wind and temperature upon request. Make sure to say Alexa “ask weatherflow the temperature”

Yes, the Smart Weather Alexa skill is online but this is a common issue: Alexa often misunderstands the request if you don’t use just the right syntax. One way to improve this might be to change the “invocation name” from “WeatherFlow” to something more distinct. Ideas?

How about using “David” or at least “Sky?”


How about “Thor” as in the Nordic god of thunder and lightning? Maybe the speech code would confuse it as “for” or “four” if not enunciated clearly enough?

“Zeus” (Greek god of sky) would be another option, but then I could see it getting confused with whose/who’s.

Personally, I gave up and pulled the plug on my Alexa thingy a few months ago. It really became annoying to watch Star Trek re-runs on TV with the Alexa wake word set to “computer” and have it start babbling several times per episode…

1 Like

Checked what the system thought I said and it was correct. The system just didn’t return the weather metrics from the WF system. Alexa simply replied back what the forecast and temps were from what ever data base its uses.

@Phoenix Can you check in the Alexa app and see if the Smart Weather skill is still enabled? If it is, try disabling it and re-enabling it. Let me know if that clears things up.

Disabled and enabled the skill from the smart application. Will test the system upon my return to home!

Upon my return home Alexa now operates as expected. Not sure why the skill had to be disabled / enabled but that was the solution and can receive micro weather information when needed.

Thank You!

1 Like

Some Alexa skills seem to be less stable than others with well documented history of disable/enable solutions. My Logitech Harmony skill needs the disable/enable routine every few months. Quick and easy but hope it gets fixed in time.

1 Like

@Phoenix I’m glad that cleared things up for you.