Air won't connect, Huawei non-standard BLE (Solved)

OK, my batteries arrived at last. So I followed the instructions and have the following to report, both as feedback and as a stuck can’t fix, can you help me plea:

  1. Again, sorry, but I find the whole experience a tad less than satisfying and rather bewildering for a total lack of clear understanding as to what to expect and how to proceed if something isn’t going as planned.
  2. So I plug the hub in. It has a light on it, that comes out, then goes out. I start the Android app and it can’t see the hub. Fine, so I replace the cable (use the one you packed rather than mine), and no change, so I move to another power supply and same issue, so I move to one that has an ammeter built in, that I use for diagnostics a lot, and is high powered (I’m kitted out here, and all these supplies provide the 1 amp you ask for and are in regular use charging a variety of devices). The ammeter equipped on reveals bizarre behaviour I can’t explain. The hub draw 0.02 amps as the LED lights, then the LED goes out and it draws 0. So I happen to have one device in the house that has hair pulling bizarro behaviour like this (my wife’s iPhone - won’t touch apple myself and less likely to because of this experience of hers). That device when it goes 100% flat she sees similar behaviour from but leaves it plugged in for a long time and eventually it starts drawing current and charging … but there’s this longish window of time where it does this bizarre minimalist draw thing and won’t start. Now I’ve had this hub in for over an hour and it’s drawing a weird up and down cycle bouncing between 0.1 amp and 0.02 amps but the LED is constantly lit. You know, this is not inspiring me somehow … I wonder why. But anyhow, as it happens I now connect to it with my Android App and it connects and we’re all happy.
  3. So I put 8 batteries of the exact recommended type into the Sky and click Next and it sees the Sky and I can register it. I’m asked to enter a pile of details like height off ground and such that are totally meaningless just so you know, because I’m testing it in my danged living room. I’m not about to go mount this thing on the roof before testing connectivity now am I? So you may as well have at least a little note on the app saying, this data is only needed once it’s been situated and if testing not to worry about it, but I did that anyhow obvious. And it seems to work.
  4. So I try to add the AIR. But it is never detected. Aaargh. Literally left it searching for a half hour while I put a child to bed, and still didn’t find it. Get this the hub and air are standing side by side. The LED on the hub is on. The AIR has a LED but aaargh it does the same bizarre stuff, when I insert the batteries it lights, then goes out again. So I try connecting in the small window of time while it’s on. Nope. This is from the same batch of 12 batteries I bought and they work in the SKY. Anyhow, I replaced them with plain Alkalines, and same behaviour. I’ve rebooted my phone and same behaviour. So I unplug the hub, wait a bit (to let any capacitance fade, though am puzzled, does it have a battery in it or does it want to be plugged in permanently? Suddenly I have an epiphany, it probably has no batter so nothing to charge just draws power as needed, like a RPi really - wouldn’t surprise me to find one inside :wink: and so the power draw is probably totally kosher and fine. Why draw power when doing nothing, and bursts of 0.02 amps for little checks and up to 0.1 amps is talking bluetooth with ma phone or such maybe? Anyhow, when I plugged it in, a new thing happens, a rainbow this time, the LED is red first, then green then settles on blue. I have a gut feel this is flagging the Wifi connection cycle, Red not connected, Green got connected, Blue steady state or such. But I’m going to have to go rooting around for documentation in the hope it exists as the installation notes mention nothing about what I should expect here. Then again it’s just gone green again and seems happy to stay there.but phone is still just whirring with “Please wait while we locate your device”. I back out and start a new AIR add, but same effect. Grrrr. No AIR.

So there you have it, some feedback on a first test. Slick box, slick product, really excited about putting it into service. But really thin installation notes and nothing in the way of guidance re: failed connection, or diagnostics a and a generally cryptic and frustrating first experience. And that’s something I’d suggest working on, but in the mean time, what can I do to get my AIR connected, and diagnose why it’s not being seen.

To recap:

  1. I have power cycled every element several times, phone, hub, AIR.
  2. I’ve changed cables, chargers, batteries.
  3. I have cryptic LED behaviours, that aren’t documented in the installation guide
  4. I have connected to the Hub and SKY successfully and am seeing 0 readings from SKY, which is probably totally expected as its indoors, with no wind, no rain and no sunlight … actually looking now it does see 27 Lux, and apparently seem 0.5mm of rain in the last hour which is interesting given we’re indoors, but then I’ve been handling it so that might be the reason. Anyhow the Hub is clearly in Wifi, the phone on Bluetooth, hub functional, SKY functional, AIR not connecting.

What can I do? How can I proceed?

Hi Bernd. Thank you for the feedback and sorry you’re having such a time getting your station online! Thankfully, your experience is pretty uncommon - the process works pretty smoothly when the hardware plays well together. But we are just getting started and there is certainly lots of room for improvement, especially when it comes to handling exceptions, which it sounds like you have encountered.

More specifically, it sounds like your core issue is the Hub not being able to see your AIR. It’s possible your AIR was not reset at the factory, and it may simply need to be reset:

Please try holding the button down for 5+ seconds until you get a slow flashing green light

Once reset, you should be able to add the AIR as usual: Settings->Station->Your Station->Manage Devices->Add Device (+)

Note, the app should have guided you to that step, but it sounds like it didn’t. If that doesn’t work, please have a look at our troubleshooting guide for a more things to try.

If you’re tried everything and you still can’t reset and/or add the AIR to your station, please drop a note to support@weatherflow.com and they’ll be able to help you with more troubleshooting.

Here are some responses for to your specific points:

  1. Thanks - we’ve put a lot of time into making the first-time user experience as easy and painless as possible, but as I said above: there’s always room for improvement.
  2. Connecting the Hub. When you add a station, you’re prompted to plug the Hub in. After boot up, the light on a new Hub will be RED (indicating no connection) until it’s added to a station via the App. Once added (i.e., you’ve created the station and entered the Hub’s serial number), the light will turn BLUE (indicating connection via bluetooth to your phone/tablet). After you set up WiFi and close the app, the light will turn GREEN (indicating connection to the Internet via WiFi) - this is the normal state of the Hub. Note, bluetooth connections are finicky, especially on some Android phones. If the Hub has power and the app is running and you DON’T see a BLUE light, you may need to restart your app and/or toggle the bluetooth radio. Note, it’s normal for the hub to draw a variable amount of power depending on what it’s doing.
  3. Add SKY. Glad you were able to add the SKY easily. And you’re right: a station’s metadata (name, location, height above ground) are not necessarily known during setup. This is a point we’re aware of and we’re working on a better way to separate “setup” from “operation” in the app. Look for that soon. Note, you can always come back and change those values once your devices are installed.
  4. Add AIR. If the LED shows briefly, then goes out, your AIR probably needs to be reset. The app should guide you in this case, but perhaps it’s not making it there for some reason. Did you ever see the screen shown below? In any case, holding the button down for 5+ seconds should reset the AIR, and then you should be able to add it easily.

Good, that never hurts.

Again, can’t hurt. But it doesn’t look like this is your issue.

The LED behavior is documented in our troubleshooting guide,.

1 Like

Thanks enormously for the prompt, understanding and informative response. Just to be clear, while frustrated with the experience I am seriously impressed with the product in general, its goals, quite excited about getting it into service. Having worked in sales, customer support and related areas for years I know too well, how such an experience represents an opportunity (with good support it becomes a very positive one, and without it it a negative one), and so far you’re definitely on the right track and I’m not cross with weatherflow in any way. Just frustrated with my experience so far alas. Part of which might stem from the reality of squeezing looks in on it between the attention demands of three children and everything else … so I feel a tad hurried alas much of the time.

The LED diagram on troubleshooting is awesome.

I had some trouble finding the button mentioned here: “Reset the device and divorce it from your hub: press and hold the clear button near the battery door for five seconds and release when LED turns green.” which again is simpel feedback. I looked and looked, I opened the door and looked, I rechecked the guides, I checked the hug, and my best candidate for a moment was a pinhole above the USB port on the hub, but discarded that option because the hub has no apparent battery compartment and the comment most definitely seems to be asking me to reset the device (AIR or SKY) not the hub. So back to the drawing board I went through all that again and only ten had a small epiphany, maybe the flashing LED is a button too … unusual but a design I’ve seen, so I press it gently and voila it depresses and hold it and then the LED is flashing green rapidly which is a good sign a reset sequence is in effect.

I let it go and the AIR is now flashing a green LED in a cycle about 1 second long, but won’t connect still.

The hub was green this morning, and when Is tarted the app, blue, so that looks awesome and as expected!

But the AIR is still flashing. The troubleshooting guide has a puzzling 15mins written against that flash, which warrants clarification. It is so beyond expectations of any boot cycle that it smacks of a typo or if it’s not warrants clarification - for example is there no point in trying to pair it with the hub using the app while it’s flashing? As it seems not to be working

I shall as ever leave the AIR for a while and check back, if it’s still flashing by the time I have to go to work, I won’t be seeing it again till this evening.

Well, it stopped flashing. Though the guide:

image

suggests that this long flash (1sec cycle) is Initial state.

Still I can’t join. So I power cycled the hub again. Still no join. I power cycled my phone. Still no join. All I see is this endless cycle:

Screenshot_20180629-100210

So I tapped the button again and it enters the 1sec cycle green flash, and repeat, all with no success.

I suspect I’m expecting the green LED on the AIR to start flashing rapidly when it is handshaking with the hub and then settle on green when it’s joined the hub. But none of that is happening.

Ok, thanks again for the detailed feedback. It helps tremendously. The slow flash indicates it’s in “pairing mode” (we should probably add that to the docs) the “15 min” duration is how long it will stay in that mode before giving up and going back to sleep. Tapping the button or power cycling it will start the 15 min timer again.

With the AIR in flashing a slow green, it should pair to the Hub unless the hub thinks it’s already paired, which can happen. Please try these steps and let’s see if you have better luck:

  1. kill the app (swipe it out of memory)
  2. unplug the Hub
  3. open the battery door on the AIR
  4. plug the Hub back in and wait a few seconds for the Hub’s light to turn solid green
  5. start the App and wait a few seconds for the Hub’s light to turn solid blue
  6. close the door to the AIR and wait a few seconds for the light to start flashing a slow green
  7. Go to Settings->Stations->Your Station->Manage Devices->Add Device (+)
  8. Follow the prompts in the app

If that doesn’t work, something might just be wrong, electronically, with your AIR (although the light would normally turn RED in that case).

Let me know how it goes!

1 Like

Was a little distracted of late, but finally got around to this again. That was an adventure and half I’ll admit. I followed your instructions to the letter. I uninstalled the whole app form my phone, I powered everything down, I reinstalled the app, I logged in etc. But alas the hub had a blue LED on so a bluetooth connection was apparently up yet, the app said after a long search:

Screenshot_20180701-221817

I was about to pull by hair out. But because I hadn’t taken that screen shot I did it all again! To get the screen shot. When it struck me, that one thing I had not tried … is to reboot by phone. So I did that. And subsequent to that, finally it found the hub AND AIR! Yes! Champagne on the house!

What a journey.

I think the product looks awesome I have high hopes for it, but these first experiences are something for you to work on and iron out as best you can I guess. From what you’ve said my lousy experience has been the exception, and so that is both good and hopeful and bad (because rarer problems are harder to diagnose and fix alas but in a less enamoured - in the idea of SmartWeather - customer than I might be seriously jaded by). Still bottom line is it was a crowdsourcing, is a new development and we all went into it knowing that and with patience in our hearts (much needed given the passage of time since contribution till now) and I still feel inspired and thrilled that you have actually achieved this result where some projects folded taking contributors cash with them alas.

I look forward now to mounting these units outside and seeing how they far over the coming months.

Thanks very much for your attentive support and what will hopefully be an awesome experience to come.

1 Like

Problem is with the phones today, even if you send the app to the background, they stay active, even when you reboot the background state comes back (and the link opens again when coming live)

On Android you have to really go kill the app, and on iPhone double tap, swipe up to really close it.

So what you describe fits in this case. Not sure how WF could to better as it is the phone not closing down the BT link …

Anyway, happy to read you finally made it. Enjoy learning the station

Thanks for your persistence and follow-up here. I’m very glad to hear you got it working! I should have added “reboot your phone” to the recipe! I will do that if we come across this again…

This underlying problem sounds like an issue with the phone’s bluetooth implementation - the phone was holding the connection open at the OS level when it should have dropped it after the app was killed. So the app, once restarted, could not connect.

Please let me know your phone’s make & model as well as the version of Android it’s running. We’ll try to duplicate that here and, hopefully, figure out a work-around for this case.

1 Like

I have a Honor v9:

It’s worth checking if at the app level you can perform the necessary low level resets or send a message to the hub to do same I guess. I appreciate the complexities of working with modern phones alas, but it’s clearly worthwhile considering a good and thorough state reset in an app like this.

Still, there is another issue at play, whatever it is is, that doe seem to be a phone issue, but still we haven’t nailed what it is so much as worked around it.

We observed in this experience at least two puzzling behaviours:

  1. Phone connected to Hub and Sky and happy as Larry reporting stuff, but when trying to add Air just can’t see it. No matter how many Air, or Hub resets we did. It seems the total uninstallation and reinstallation of the app got around this. Biggest puzzle beig whether the Hub saw the Air or not and what diagnostics there are for that, and whether the hub could communicate that to the phone or not.

  2. Phone won’t connect to the hub, even though the hub has blue LED up, and again in spite of Hub resets and even total total uninstallation and reinstallation of the app! But a phone reboot after a total uninstallation and reinstallation of the app got around this. Puzzle being that the hub thought the link was up, the phone couldn’t see it.

One idea worth considering is to give the hub a wifi interface. The challenge that everyone has with this is of course that of connecting to the WAP in the first instance and nees to configure that. WPS is a questionable strategy in that space but most devices I work with still seem to offer a standard RJ45 socket one which that have NIC (chip) that will have a default IP address and/or use DHCP by default. So I plug it into the LAN, check my DHCP server and then can connect to its web interface which asks me to configure the wifi connection, after which I can unplug it and connect over wifi.

A web interface to a thing like this hub is awesome of course. Not sure if it has one or not, haven’t checked yet ;-). But in any case such an interface would act as a nice fallback and work around in times of bluetooth problems. Of course it’s another port on the hub, and possibly chip on the board never mind the software needed it needs.

Anyhow, I look forward now to mounting these and rolling …

One problem I have is with the Sky recommendation of 3m above the roof. Hmmmm, a mild bother when it comes to changing the batteries. If 2m sufficed battery changes would be an easy job. 3m is a whole new ball game alas in terms of how I mount it. So wonder if you have comment on 2m vs 3m and/or what impacts proximity creates - it’s a digression so maybe move that elsewhere. I mean I have a perfect spot on my roof, where there’s a TV aerial, and I’d extend that upwards with a 1" pole without drama, but I’m also 1m or 2m above an aerial then. Not that it should matter as it’s a passive reception aerial (that we don’t even use actually as we don’t watch TV, it’s just part of the house) and not transmitting.

I cannot seem to find the reset button, i do not know IF I am going blind. I cannot find anything that resembles a button Close to the battery door in the Air.

Can anyone insert an image showing where it is?

Open and close the battery door.

Did you notice the light? That’s the button.

1 Like

Ooh. I did not think of that, thank you.

1 Like

Sorry for the late response - your reply slipped through the cracks.

We actually gave this idea a LOT of consideration. We tested 50+ smart home devices, most of which had some sort of WiFi interface. Some worked okay, some worked terribly, others didn’t work at all. The problem is the WiFi spec doesn’t have a standard way for provisioning a device that doesn’t have it’s own user interface. So devices without one have to perform all sorts of gymnastics to set up the WiFi.

The Bluetooth Low Energy (BLE) solution works REALLY well when it works, which fortunately is most of the time (search this forum and you will not find many experiences similar to yours). That apparent smoothness actually requires a massive amount of exception handling in the app, especially the Android app, due to variations in how each manufacturer or OS-provider chooses to implement BLE.

My guess is your Huawei phone’s BLE implementation is doing something our app is not expecting and/or is not responding to the many work-arounds the app already tries in an attempt to connect to a BLE device.

Thanks for your detailed reporting though - if we can get hold of a Huawei Honor 9 (looks like a nice phone!), we might be able to figure out what’s going on.

We actually do have a web interface (https://smartweather.weatherflow.com), though it doesn’t make a direct connection to the Hub because there is not one - as you suspect, running a web server on the Hub would take more power, more processing, more ram, and would open up a lot more security issues. While it doesn’t allow a lot of device-level configuration yet, ultimately the web interface will allow configuration of everything except the initial WiFi connection.

The 3m suggestion is a rule of thumb. It depends strongly on other factors like the shape of your roof, the surrounding trees and buildings. In general, the closer to the roof you go the more subject to boundary layer effects your wind measurements will be slower and gustier on average. I would post this question as a new topic in the #owners category, or perhaps post it to this thread: Photos of Sky and Installation

Is the Huawei issue related to what I saw in the VictronConnect documentation? It used BLE also. This is a screen capture from the docs. Screenshot_20180717-120216_Edge

Possibly, though I can’t say for sure since we have not tested any Huawei phones with the Hub yet. It’s interesting that teh Huawei P8 listed there only works when location services are disabled. I’m not sure why that would make a difference but, as anyone who’s played with it for a while knows, BLE still has some issues in terms a “standard” implementations!

2 Likes

Just a sidenote on Bluetooth… I am involved in a company that makes smart running sensors… When the first product launche, found several odd issues regarding how bluetooth was implemented between manufacturers and models e.g. galaxy 6 and 7.

Problem being that manufacturers do nort follow certain guidelines issued on Bluetooth implementaion.

2 Likes

A big issue with Huawei phones is the aggressive killing of background applications. VLC has joined to ranks of companies blocking Huawei phones from installing applications.

1 Like

For the record, I’m connecting fine with Bluetooth to the hub now with my Honor v9, and haven’t had problems in a while. We did nothing really other than reset everything to get to this stage. Including Hib, AIR, SKY, Phone … but all seems fine.

Not that I use VLC on my phone I do take grave issue with VLC or anyone blocking a phone or any device on basis of its power management strategies. Pathetic IMHO. If anything I have always set my phone (any brand as Android phones have always to my memory had this facility either built in or provided by an app I could download) to boot idle background apps from memory. There has always been and is on this one a whitelist that is spared this treatment. It’ not a Huawei issue, so much as a sensible thing to do on a phone with it’s limited memory and resources and the propensity for every single app ever opened to stay in memory - the phone OS simply never made a clear distinction in is design between closing an app and hiding an app and this is the consequence I guess.

Also VLC is FOSS:

And so this stupid move is nothing more than an incentive for someone to maintain a fork that runs fine on Hwawei phones I guess ;-). Even if it weren’t FOSS, a move like that, almost especially one that discriminates against Chinese or Russian products, is attacking a market that is literally flooded with young hacking talent and motivation to just keep the cat and mouse game running where someone writes an app that enables said software on that phone (if it’s only a ban based on brand line …).

I’m happy to know all is well with the WeatherFlow application. It’s so difficult to troubleshoot an issue since we can’t trust that the phone and OS are actually preforming as we expect.

1 Like

I’m glad too ;-). FOr what it’s worth the only reason I think we need the BT connection anyhows is to set up the wifi link. Which I did again just a few days ago as I moved to hub to a place where it gets stronger signals form SKY and AIR and that is not in the house but in a garden studio with another WAP. The BT connection was fine and knowing the LED colors on the hub now also very reassuring. All went smooth. But aside from that it seems I can do everything else form a web browser once the hub is on-line anyhow.